Fifth generation of iPhone. Repair of this device is straightforward, and requires screwdrivers, prying tools, and patience. GSM/CDMA / 16, 32, or 64 GB / Black or White.

2988 Questions View all

iPhone 4s bootloops. Can't restore. Error code 3uTools -2

I managed to successfully flash iOS 6 onto an iPhone 4s and it worked fine. I then had to put the back cover on and put a few covers back and when I was doing that, I accidently shorted the battery positive to the case. It was only for a fraction of a second and judging by the location, shouldn't have harmed anything. Even so the battery is pretty much dead anyway. Now onto the strange stuff. When I tried to power it on after this, it was stuck in a short bootloop and wouldn't turn on. I have tried both iTunes and 3uTools to recover the phone but I get error 21 with itunes and error -2 on 3uTools. Any suggestions much appreciated!

Answer this question I have this problem too

Is this a good question?

Score 0

Comments:

Managed to solve this by replacing the battery with my lab power supply. This is definitely a battery-related issue.

by

Yes, error 21 was associated with battery issues.

by

Add a comment

Free shipping on all orders over $100 or containing a Pro Tech Toolkit!

Browse Our Store

1 Answer

Hi

a repair guy here. As the iphone 4S is pretty sturdy, touching the case with the battery connector should not damage the phone.

And iff I understand your problem correctly it is pretty similar to not having the battery connected at all.

Try to disconnect the battery and see what happens if you put the cable in. It will show the apple logo for a few seconds, than go black and restart.

During an update or booting it there is a moment it needs battery power even with the usb cable connected to the phone.

If if that’s the same as when you have your battery connected, you’ll need to exchange the battery.

If that doesn’t work check the connector soldered to the motherboard. These are known for some wobbly soldering points. You might have damaged them when disconnecting the battery.

Last at thing I can think of, is to test with an new dock connector flex, but that is not something that is usually related to error 21.

Was this answer helpful?

Score 0

Comments:

I managed to temporarily fix this by powering the iPhone from my lab supply. I've ordered a new battery anyway. As you said, I noticed that it needs the battery during update and just reboots (not going into recovery mode) at some point.

Thanks for your help. You might be helpful in the future!

by

Add a comment

Add your answer

jamiebrowm will be eternally grateful.
View Statistics:

Past 24 Hours: 4

Past 7 Days: 19

Past 30 Days: 51

All Time: 87