Skip to main content

Fix Your Stuff

Right to Repair

Store

Huawei's 2017 flagship smartphone. Released in March 2017. Features a unibody case and dual rear-camera setup developed in partnership with Leica. Comes in 32/64 GB storage options and six different finishes. Model numbers VTR-L09, VTR-L29, VTR-AL00, VTR-TL00.

38 Questions View all

Water Damage and still wont load

Hey all my first post :D now i love dealing with pain phones so i took this one on a Huaweii P10. All ive been told is it got wet it worked for a while and then it turned off. What ive done so far :-

Cleaned board with 90% alcohol stuff, that solution that Ifixit recomeneds

New Battery

New Charging Baord

New Main Flex

New Screen

When i plug the charger in all that happens is the red light on the screen flashes, it does this with the battery plugged in and out also when i press Power Up + Power i get the flashing light but i press just power i get nothing. When i got the phone it had enough power to cycle vibrate as it trys to turn on so its got to be the battery not charging.

Any body have any words of wisdom for me to try or does this need to go to someone with a sonic bath :)

Many Thanks

Simon

Answer this question I have this problem too

Is this a good question?

Score 1

Comments:

Did it show signs of corrosion before you cleaned it. There's possibly a short which is why it won't turn on

by

yeah there was corriosion but i cleaned it all, only part i cant get to is under the shields but still im getting the flashing red light nothing else. Guess this one is a loss.

by

I decided to clean the board one more time last night :) dried it off with nt heat gun on low settings and left all night. Hooked it all to this morning and put it on charge now the red has gone and been replaced with a solid white light that turns off when I hold the power button

by

Add a comment

The Essential Toolkit

The most helpful tools in our most compact kit.

Shop Now

The Essential Toolkit

The most helpful tools in our most compact kit.

Shop Now

1 Answer

Most Helpful Answer

Hi @simong93 ,

Usually under the shields is where the problems are because the water gets trapped there and takes longer to evaporate which doesn't help if the power is reconnected before it has or stop the corrosion once it has evaporated.

The only chance, slim that it is, is to remove the shields and clean it and hope that it might work

You could try and use an ultrasonic bath to try and clean it but again I think that the damage is already done and it is too late.

Was this answer helpful?

Score 1

Comments:

I decided to clean the board one more time last night :) dried it off with nt heat gun on low settings and left all night. Hooked it all to this morning and put it on charge now the red has gone and been replaced with a solid white light that turns off when I hold the power button

by

Hi @simong93 ,

If you didn't remove the shields, that still leaves the corrosion which will come back to haunt you sometime in the future.

Drying out a device doesn't remove the corrosion which in itself can provide a conductive path (resistive admittedly), which shouldn't be there in a circuit.

You really have to clean it all away thoroughly to ensure that there are no problems.

by

Add a comment

Add your answer

Simon Gilbert will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 4

Past 30 Days: 16

All Time: 352