SSD slows when changing Bay (between main bay and optical bay)

SSD running OS X [Sierra or High Sierra] can be made to perform well [= read/writes at 400-500 MB/s ] in both Sata III bays (whether the main bay or the optical drive bay).

Problem: When moving SSD from one bay (main bay or optical drive bay) to the other, it would perform very slowly. The SSD seems to work fine in whichever bay the SSD was in when it was originally installed (whether the main bay or the optical drive bay). It was only when the SSD was moved to the other bay that I began to see highly variable read/write times, which at times were normal [400-500 MB/s ], but most times were very [<100 MB/sec]. Running Sierra and High Sierra (problem manifests in both versions of OS X).

Note 1: I have tested both my main bay and my optical drive bay, and both are Sata III (I have achieved read/write speeds between 400-500 MB/s on both bays).

Note 2: The problem is not SSD specific. For example, I have built OS X Sierra on a Samsung 850 (500 Gb) in the optical drive which functioned fine [400-500 MB/s ] until it was moved to the main bay, it became too slow to be useful. When I reinstalled OS X Sierra on the same drive using the Sata connector in the Optical drive if functioned fine [400-500 MB/s ], until I moved it to the main bay, at which point it became extremely slow. I have repeated the same experiment with a Crucial MX 500 to the same effect.

Note 3: Seem to have the same problem whether in Sierra or High Sierra

Any Ideas?

Answer this question I have this problem too

Is this a good question?

Score 1
Add a comment

2 Answers

Most Helpful Answer

You’ve hit a known issue within some MacBook Pro systems!

Review the Red notes here OWC - Data Doubler The issue is the system not the carrier. The Optical drive bay is just not able to run at SATA III (6.0 Gb'/s)

To add to the problem your Samsung SSD being an auto setting drive (one that is able to match up with the systems SATA ports data rate) is unable to sync up with the port so it makes this worse. You’ll need to get a fixed SATA II (3.0 Gb/s) drive to use your optical drive port like OWC - Mercury Extreme SSD.

Don’t even think about swapping your HDD drive to the optical bay, as you’ll be only putting it at risk! The HDD bay has special crash guard services to protect your drive when you bang your system or put your system into sleep mode and move your system about.

Update (09/16/2018)

OK, if your system is not marked with a Red note then you do have a system which is able to support SATA III I/O (6.0 Gb/s) don't trust the hardware profile. Just because the PCH offers SATA III (6.0 Gb/s) the drive link speed is what you need focus on with the Optical bay drive. If it does not link up at SATA III (6.0 Gb/s) then you still have an issue with the bay)

As far as the HD bay you likely have the original SATA cable which was only rates for SATA II (3.0 Gb/s). You'll need to get the newer version of the cable MacBook Pro 13" Unibody (Mid 2012) Hard Drive Cable This cable is the better one the (and yes! its for the ‘12 model). You also want to place electricians tape on the uppercase where the cable crosses over as the rough surface of the aluminum case often kills them. Lastly, you’ll want the arc the corners don’t bend them into tight creases! The foil wires inside will be damaged!

MacBook Pro 13" Unibody (Mid 2012) Hard Drive Cable Image

Product

MacBook Pro 13" Unibody (Mid 2012) Hard Drive Cable

$44.99

Was this answer helpful?

Score 3

Comments:

Thanks Dan,

Quick response appreciated. I forgot that these old machines cut power to Optical bay when in sleep mode. Indeed, when connected to the optical bay, my system cannot recover from sleeping. So, not a solution for the OS.

Per the OWC report, some 2011 MacBooks have Sata III optical bays, as seems the case with mine. [How else explain how read/write speeds of (400-500 MB/s)? … much faster than the 3Gb/s Sata II limits.

The problem remains the inability to swap drives. The OS X was installed on an SSD the optical drive, and for some reason I can't just pop that SSD into the main Sata bay without the speeds dropping off.

As stated above, its likely NOT a hardware issue, since just last week, the same SSD was booting and running OS X at full Sata III speeds (400-500 MB/s) in the main bay and since I have another SSD that and runs just fine (350MB/s-450MB/s) in the main bay (but too slowly in the optical bay). The problem seems to be the swap itself.

Any ideas ?

DK

by

Add a comment

EDIT: Sorry, Posted this a while ago but got marked as spam.

Pretty much what Dan said…


Not entirely sure, but I remember reading that Apple did not recommend using a 6gbps capable SSD in the optical bay, but to only use 3gbps.

That may, or may not, have something to do with it.

eg:

”Testing has demonstrated that Apple factory hardware does not reliably support a 6G (6Gb/s) Solid State Drive or Hard Disk Drive in the optical bay of 2011 and 2012 MacBook Pros (Model ID 8,1; 8,2; 8,3; 9,1; 9,2). “

from https://eshop.macsales.com/item/OWC/DDAM...

Otherwise, make sure trim is enabled and run fsck -fy on the drive in question.

Apparently that has helped some people resolve speed issues.

and of course, the usual reset PRAM and SMC… :)

Hope this is of some help.

Was this answer helpful?

Score 0
Add a comment

Add your answer

D. K. will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 50

Past 30 Days: 50

All Time: 50