Skip to main content

Amplifiers for home audio systems.

54 Questions View all

I have akai am-m830 no power?

I have just dug out my old akai stack but the amp isnt recieving power checked all the fuses inside and out nothing seem wrong but lights flick on then off what could this be

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

MacBook Battery Fix Kits

Starting at $69.99

Buy Now

MacBook Battery Fix Kits

Starting at $69.99

Buy Now

1 Answer

Most amps and stereo systems have protection against liquid ingress, take the top off and leave it to air out in a room at a reasonable temperature. If it has been in storage it could be condensation on the main board., if so airing it out could fix it.

Was this answer helpful?

Score 0

Comments:

I will try this it was thick with dust so i have cleaned it all out hopefully things will change tomorrow cant wait to play some old skool tapes

by

Excellent, please come back if it works or not, there might be more you can try. Good luck.

by

Still nothing im going to pull the rest of the decks apart for a thorough clean any thing in particular i should look out for ?

by

That's a pity. Just check that there is no crud connecting chip pins on the board. If you could also add a picture or 2 of the board I will have a look at it to see if there is anything I can see.

by

Add a comment

Add your answer

Stefan miles will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 4

All Time: 36