Skip to main content

Repair guides and support for televisions manufactured by Sony.

595 Questions View all

Please help! Vertical Lines on Tv Sony KDL-42W700B

Hi, Please refer to attached pictures. My tv just started showing this.

It start with Black image and then after some time it goes back to Normal.

Please help, what should I do ?

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

Answer this question I have this problem too

Is this a good question?

Score 2
Add a comment

4 Answers

Most Helpful Answer

Himanshu Rathore  could be the LCD driver board (which is not repairable) but there is also the possibility that you are having cable issues or an issue with the T-con board. I suggest that you remove the back of your TV and check all the wiring. Disconnect the wires and reseat those to make sure they are properly attached. Post some images of your boards with your question so that we can see what you see. Use this guide Adding images to an existing question for that.

Was this answer helpful?

Score 2

Comments:

Hi @oldturkey03 , thank you for the revert, mine is an LED TV, you mentioned LCD driver board, is it the same thing for LED TV? Also, I have never open a TV before, If I'll remove the back cover I am afraid that I will do more damage to the TV, what will you suggest, is it ok for me to do it on my own ?

by

Himanshu Rathore removing the back is not going to harm your TV. Keep it unplugged and do minimize touching the boards with your fingers. The LCD driver board is actually part of the LCD panel. There really is no LED TV. Those are advertising gimmicks. An "LED TV" is called that because it uses an LED backlight. The panel is still an LCD panel.

by

@oldturkey03 initially when this problem started, the tv would become normal after 5-10 mins. however, thats not happening now and it is taking as good as half to 1 hour to things go back to normal. However once its normal, then it works smoothly till its not switched off.

by

somwthin glike this "tv would become normal after 5-10 mins. " is usually related to bad capacitors and to a lesser extend power transistors. Take a look at the boards and let us see what you see.

by

@oldturkey03 I have called a TV technician today will get the board cover open and will share pictures here with you. Thanks a lot for your assistance.

by

Show 2 more comments

Add a comment

The band is roughly a sixth of the screen width, so I'd guess there are 6 chips along the top (or the bottom) of the screen controlling the columns of pixels. It looks like chips 1, 2, 3, 5 and 6 are ok but 4 is faulty. Most likely it's the connections to the chip which will be very fine and unfortunately not really repairable.

Was this answer helpful?

Score 1

Comments:

Hi @pleriche thank you for the revert. is there any way to verify that this is the chip issue? and can you guide on how to repair this? the service centre guy was saying that It is because of Panel issues and is asking 1/3rd of the TV cost to repair it.

by

Add a comment

If I am reading your post correctly, the TV starts out with a problem and then corrects itself after a while?

If this is true, I would suspect either an IC that is sensitive to heat or there are connection problems somewhere in the video path. As oldTurkey suggested, try re-seating all of the cables first. Any dirt or corrosion within a connector can cause this type of failure.

You can narrow this down a bit too with a simple test: Does the menu appear correctly at all times or does it too fail in the same area? If the menu works but the standard signal does not, then the problem is in the logic board and is not a display problem.

Update this when you can.

Dan

Was this answer helpful?

Score 1

Comments:

Hi @abrsvc , when I start the TV, even the logo is missing. The black patch in the centre remains black and after some time everything comes back to normal. initially, when this problem started, the tv would become normal after 5-10 mins. however, that's not happening now and it is taking as good as half to 1 hour to things go back to normal. However once its normal, then it works smoothly till it's not switched off.

by

This is a heat related issue. It may be as simple as a poor connection or bad cap. It may be a connection under one of the ICs which would require a "reflow" as well. Can you take the back off and post a few pictures of the boards? We may be able to spot something.

Dan

by

@abrsvc I have called a TV technician today will get the board cover open and will share pictures here with you. Thanks a lot for your assistance.

by

@abrsvc Hi, pictures attached for your review. Also, TV is now no more going back to normal now like earlier, so that black patch in center remains as it is.

The technician who has come has inspected the TV said that the problem is with *panel* and their are 70% chances of repair. I don't even know what does that mean,their are only two outcomes 1)Repairable 2)not repairable. (now what does 70%means)

by

Add a comment

It's a display problem bro..

You have to change display or if the display is unavailable talk with Sony service executive for alternative

Was this answer helpful?

Score 0
Add a comment

Add your answer

Himanshu Rathore will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 7

Past 30 Days: 24

All Time: 4,593