Skip to main content

Model A1502 / 2.6 GHz (Turbo Boost up to 3.1 GHz) or 2.8 GHz (Turbo Boost up to 3.3 GHz) dual-core Intel Core i7 processor with 4MB shared L3 cache.

471 Questions View all

question mark after installing new SSD flash

Block Image

i am occurring a problem.

My MBP 13 inch 16gb Ram and 256 SSD flash was working fine till a month ago.

A question mark is being displayed in the screen.

a lot of answers reading and Cmd R doesn't see the drive only the recovery part.

External drive installed and it works.

So a new SSD drive bought and installed. Still the same problem. CMD R disk utility doesn't see the drive either.

So maybe the old drive isn't bad.

Are there any smart Apple fans here who can help me.



The Netherlands

Answered! View the answer I have this problem too

Is this a good question?

Score 1

Can you explain who’s SSD you used and how you connected it.


A transcend 820 240gb ssd. Special for a mbp. The connection is just unscrew the Apple one, click iT out and put the new one in.


The reason I asked is there are a few different drive setup people are using so without knowing the drive and how its installed it can be confusing.


I believe this happened to my brother before he made the move to windows. Is the drive compatible, was it installed correctly? I'm not really good at this, Dan will help you better all I can say (again) was is it installed correctly, have a look:

MacBook Pro 13" Retina Display Mid 2014 SSD Replacement


I installed iT correctly using the instruction on ifixit.

There is No ssd cable. So.....

Maybe Some dust


Add a comment

2 Answers

Chosen Solution

The Transcend SSD when new doesn’t have the OS installed so you do need to install it. The OS you had on your old drive also has a bearing here as the systems firmware is now updated when you install the OS. This can alter how your system will respond when trying to do an internet recovery which I think is what you were aiming for (CMD R). If you were thinking you can access the recovery partition it’s not there yet ;-}

I’ve found it easier and faster just to have an USB thumb drive OS installer drive configured before hand. Then booting up under it run Disk Utility and the OS installer.

You imply it was working before so the question is what happened?

It sounds like you do have a bootable external drive working here what does Disk Utility show you with the internal Transcend SSD drive when you boot up the system with the external drive? Post a screenshot if you can Adding images to an existing question

Update (07/14/2018)

OK, I think I see the problem. The drives firmware needs to be checked and it may need an upgrade. OWC had a similar issue were the SSD did not show up as an internal drive (note the drives Icon is external) So getting it to boot up correctly is an issue. Here's a reference on the OWC issue: A Note on High Sierra Compatibility with Third Party SSD's

Go to this Transcend web site: or the Transcend European site.

Let us know how it goes!

Was this answer helpful?

Score 2


I added a picture


i did it all. boot on the external drive. Tried to updated to High Sierra but now i get the message. ‘ No firmware partition’

The installation stops

I am lost


Did you check the drives firmware?


I cant update the firmware because HS will not install.

Forums All say... put the old ssd in and update. But the old is broken.

Update my external USB drive with Yosemite dooesnt work


Add a comment

@lando1971 -I lando, how did you fixed this finally??

Was this answer helpful?

Score 0
Add a comment

Add your answer

lando will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 2

All Time: 573