Skip to main content

Guides and support for various TV brands and styles.

4442 Questions View all

TV screen color is off and image delay

Brand: Element

Model: ELEFW605

Size: 60 Inch

LED TV

When an image (ie. TV Show) in on the screen, the colors are all red/black and you can sort of make out what the image/show is.

When I hit "Menu" on the remote, the TV menu slowly fades in and the screen looks heavily saturated or very high contrast (Yes I checked and the saturation, color, contrast, hue is all the same as the day I bought it).

I have tested Cable TV, video game and Chromecast so the video ports are fine and the audio is perfect.

Here is a video of what I am seeing.

https://www.reddit.com/r/fixit/comments/...

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

iPhone Battery Fix Kits

Only $29.99

Buy Now

iPhone Battery Fix Kits

Only $29.99

Buy Now

1 Answer

Most Helpful Answer

@jda3

that looks like it’s a bad main board. You will have to remove the back of your TV and take a look at all the ribbon cables as well as check for obvious damage to the boards. Check for charred components, leaking or domed looking capcitors etc. It is of course also possible that this is a failed panel. Post some images of your boards with your question so we can see what you see. Adding images to an existing question

Was this answer helpful?

Score 1
Add a comment

Add your answer

JDA will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 24