Model A1318 / 32 or 64 GB capacity

384 Questions View all

battery does not charge

when turned on get message that battery is low. Battery indicator indicates charge is low. Have tried to charge via 2 different usb port connectors and 2 wall adapters but do not get the battery icon to show it is charging and after trying both methods to charge stll does not show it has charged.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Have you tried charging it overnight? Sometimes batteries are severely depleted. But if the battery still gets no power to it, my recommendation is to replace it.

Was this answer helpful?

Score 0

Comments:

also clean your dock connector and make sure that you have a good USB cable. Check the dock connector for debris corrosion and bent pins.

by

Add a comment

Add your answer

manuelo249 will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 872