Why does Canon SD450 camera power off after a few seconds?

My rummage sale Canon SD450 came with the lens extended. After fiddling with it a few minutes it was able to retract the lens and close the cover. At home, I put in a Sandisk 128MB multimedia card and charged the battery.

When I powered up it extended the lens and I was able to take a still shot and a movie and display them. The zoom function worked, but with some roughness.

Now it is stuck with the lens extended and will not stay powered up or function in any mode. It powers down after a few seconds. With the mode switch set to play there is a brief display of a Canon startup image of a bird, then it powers down. If I press the power button while holding down the center select button I get an animated digital display of the clock time, and pressing the left or right button changes the background color of that display. No other button presses have any effect. Then it powers down.

There are no error messages or warnings. There is no display when I power up in either still or movie modes, there is a brief motor sound, and then it powers down.

I suspect maybe the lens mechanism is jammed in the open position, and that the controller senses the jam and automatically powers down to protect the system from overloading the motor.

Anyone else know about this?

Answered! View the answer I have this problem too

Is this a good question?

Score 0


your symptoms are similar to those i had with 2 of my kodaks, I was able to view saved images from the card on the lcd, scroll through the menu but that was it. The lens failure seemed to shut down the whole camera. You may find that someone has the service/repair manual for this so I'll let them answer for certain. I fixed mine with a replacement lens as i couldn't find the flex on it's own..


Add a comment

1 Answer

Chosen Solution

I do agree 100%with my colleague Pollytintop. I do have the service manual on my file server and you can download it so that you can repair or worst case scenario replace your lens assembly. The manual is RIGHT HEREThe problem usually happens because dirt or sand get into the lens mechanism. Physical obstructions preventing the full extension/retraction of the lens. These can include things like dust or sand in the mechanism.Depending on the size of the obstruction, it may be dislodged by blowing air on it or tapping on the camera.

Mis-alignment of the lens can also cause this problem. The cause of the mis-lignment could come from dropping the camera or dirt and contamination of the lens/track. You might resolve this problem by pushing the mechanism back into alignment, and also make sure that the lens etc. is clean and free of any debris, corrosion, etc.

Hope this will work for you and good luck

Was this answer helpful?

Score 2


i have got to find out where you get all these service manuals!


One of these days I will have to send you all my bookmarks and you'd be surprised how much information is available on forums out for .ru .pl. etc. :-)


Thanks for the service manual link. I have used pictorial guides here on ifixit to dismantle the camera and remove the lens/optical unit. I opened the zoom gearbox and removed the gears, then inspected and cleaned them. There was a little sand. With the drive gears removed I could rotate the base ring of the lens and cause it to partly extend and retract, but not retract all the way. There is a sliding part above the base ring that was stuck, and I got that to move after messing with it. After reassembling and testing there was progress over before, but the lens still binds when trying to retract. It got cocked to one side, and I pressed it to snap it straight. Then it fully retracted when I powered on, but did not fully extend. I got the famous E18 error display, which it never got to before. After a few more tries the lens is tightly stuck partly out, and when powered on I'm back where I started, brief motor noise then auto power off. No display. The manual doesn't include working on the lens module.


Sounds to me like you have tried all the proper steps. I did find out that at one time a Class A action suit was planned against cannon due to this error but was later abandoned. Here is a link and a guide that might help you further. http://blog.wolffmyren.com/2008/10/23/e1... the lens module is probably not included due to Cannon just replacing those. Hope this will help you a little more. Good Luck,


Add a comment

Add your answer

Nick will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 978