Skip to main content

Repair guides for machines designed to move slowly and get big jobs done, including farm vehicles and construction vehicles designed for specialty tasks.

49 Questions View all

Manual PTO not engaging blades

Hello - I have a White Outdoor LT-1650 tractor. When the tractor has been running for 15 mins or longer, the manual PTO will not engage the blades. I replaced the belt and spring thinking they may have become stretched out. This didn’t solve the problem. The engine pulley is spinning fine. When I turn the PTO lever, the pulley pushed out fine. It just doesn’t seem to be putting enough pressure on the belt. I can’t find any other adjustments that would solve this issue. Any help would be great.

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment

2 Answers

Chosen Solution

@mjones21 besides checking the idler pulley you also need to check the routing of the belt, the connection of the springs, the engine pulley and the pulley's on the deck. Make sure that all of those are in working order, not seized etc.

Block Image

Was this answer helpful?

Score 2
Add a comment
Most Helpful Answer

You have an idler pulley that has moved out of place or is seperated/seperating. Very careful inspection will tell you. Look for NEW wear marks on pulleys. Check springs too. Good luck

Was this answer helpful?

Score 2
Add a comment

Add your answer

Mark Jone will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 6

Past 30 Days: 23

All Time: 540