Model A1286. Released February 2011 / 2.0, 2.2, or 2.3 GHz Quad-core Intel Core i7 Processor

529 Questions View all

High CPU usage kernel_task

Hello everyone,

I'm having extremely high CPU usage and it's being caused by kernel_task.

When looking around on the internet for the problem most people note that their fans are going crazy and most answers to the problem seem related to the fans/heat of the mac book.

My fans are running just fine and the heat doesn't go above 40 degrees Celsius, so i'm kind of confused as of what could be the problem for me.

Tried booting it in safe mod and it was completely fine I had no troubles whatsoever, then I restarted it and after 10 minutes it was going up to 90% total CPU usage again.

(Fresh instal didn't fix it either)

I have no clue what the problem could be any help is very appreciated !

EDIT:

I just noticed that it hasn't happened ((yet)) when i'm charging it.

My macbook has been repaired in the passed and the battery has been replaced.

Could the battery be causing this issue ?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12

2 Answers

Chosen Solution

Setup an external bootable drive, see if booting under it resolves the issue. If it does you likely have a bad HD SATA cable.

Was this answer helpful?

Score 1

Comments:

Hi,

I actually saw your fix and gave it a go since i still had a replacement cable at home but it didn't work.

It was sitting idle for about an hour cause I was afraid to touch it but 5/10 minutes after I started using it again it jumped up to 90% total usage again.

by

Did you use an external drive before replacing the cable to see if it was OK then?

by

I did but nothing changed, still wanted to try it just in case the bootable drive wasnt optimal either.

I should probably also add that I had this problem with my previous HDD as well, replaced it with an SSHD yesterday but the problem still persists.

I just noticed that it hasn't happened ((yet)) when i'm charging it.

My macbook has been repaired in the passed and the battery has been replaced.

Could the battery be causing this issue ?

by

To check the battery and charger, download this gem of an app: CoconutBattery

by

Thanks !!

I think it might be the battery that's causing it I'm gonna let it get checked out. Thanks for your help !

by

Add a comment

Yes might be due to the battery issue as you have get it repaired so try to replace battery first and check it work for you or not. If it still does not work for you then do visit at Service host superfetch for high cpu usage as it can also be the reason of slow response of your system.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Megatellica will be eternally grateful.
View Statistics:

Past 24 Hours: 15

Past 7 Days: 83

Past 30 Days: 387

All Time: 3,736