Model A1285 / 8 or 16 GB capacity

243 Questions View all

apple logo loop, and it's always asking to restore

Hello everyone,

My 4th gen ipod nano works fine, until I hit menu button. Then it enters on a reboot loop and after a while, it either starts working fine, or it asks to restore. Sometimes I have to restore more than once until it starts working again.

I have no guaranty.

I've tried 5 R's.

I've restored it on both mac and pc.

I've done hard formats.

Since it works some of the times, do you think it could be a cable that is not well connected, or some other easy fix ?

Thanks in advance.

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment

Free shipping on all orders over $100 or containing a Pro Tech Toolkit!

Browse Our Store

4 Answers

Chosen Solution

I know that this particular model of Nano has issues with corrosion on the logic board. May be some of the corrosion is causing the behavior that you are describing. You could disassemble it by using the guide from here. Check for corrosion on the board as well as all the cables and connectors. Clean the board with isopropyl alcohol and change the battery while you are at it since it must be almost at the end of its lifespan. Reassemble, restore and see what you got. Good Luck

Was this answer helpful?

Score 2
Add a comment

Thanks for the answer.

I have already dissembled it, and it worked fine for a while. I think it maybe has to do with the cables..

Was this answer helpful?

Score 0
Add a comment

Is it water damaged?

Was this answer helpful?

Score 0


It is second handed, and since I have it, it isn't water damaged, but I can't be sure. Is it a common cause for this type of problem ? Should I put it in a rice bag or something ?


I do not think you will have to put it in rice if you have had it for a while. But since you have it disassembled already, take a good luck at all the cables and make sure the cable ends are not corroded. The 4th gen has some issues with corrosion. That is why it is important to clean the whole board. I use also a soft toothbrush on mine to make sure no corrosion is left. Check on the connectors as well and make sure you have no corrosion, same with the connection for the click wheel. A very close inspection and cleaning should resolve your issues unless you find it becomes more consistent, then consider to change the click wheel.


Add a comment

can someone help me with this problem without disassembling the ipod

Was this answer helpful?

Score 0
Add a comment

Add your answer

caetano will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 2

All Time: 2,336