SSD not detected by EFI

Hello all,

I got a problem with not booting SSD.

I have a first MacBook mid 2010 with the fellowing specs :

  • MacBook 1
    • MacBook Mid-2010 (7,1)
      1. Core 2 Duo 2,4 GHz
      2. 8 Gb DDR3 Ram
      3. 240 Gb SSD
      4. macOS 10.13 High Sierra
      5. (Perfectly working)

Recently i have purchased another one (exact same model) in better condition than mine:

  • MacBook 2
    • MacBook Mid-2010 (7,1)
      1. Core 2 Duo 2,4 GHz
      2. 2 Gb DDR3 Ram
      3. 256 Gb HDD
      4. OS X El Capitan
      5. (Perfectly working)

So i decided to swap the rams and the SSD/HDD of both machine.

And surpise :

  • The SSD of the MacBook 1 isn't detected by the EFI of the MacBook 2. Even when i plug it with USB adapter and press "option" key to choose boot disk.
  • The SSD is detected by Disk Utility on the Macbook 2 (with macOS High Sierra install USB Key to access Disk Utiliy)
  • If i plug the SSD with usb adapter in the MacBook 1 it works.

What a strange thing...

So i have installed another HDD in the MacBook 2 with high sierra and updated the EFI.

The SSD is still not detected by EFI.

I also tryed PRAM end SMC reset.

Last thing : In the parameters of High Sierra on the MacBook 2 HDD i can set the startup disc to the SSD (when i plug it in USB or SATA) but it's display "?" once it rebooted...

Many thanks for your help !

Sorry for my bad english.

(I have already posted the same thing on MacRumors forum but i think this forum is more technial)

Update (02/22/2018)

@benjamen50 :

Yes, the MacBook1 can boot MacBook2's HDD.

@deval82 :

Hum... I see... Maybe the EFI rom on the MacBook2 don't recognise the EFI partition on the MacBook1's SSD ?

I am going to try to install macOS High Sierra on the MacBook2 with another SSD to see first if it works, if not i will try your complete procedure.

Thanks you!

Update (02/22/2018)

So, i think i have found the problem, When i install macOS High Sierra on my MacBook2 with SSD in HFS, it can boot, if i do the same but SSD formated in APFS, it's not detected.

Now i need to know how to enable APFS on the MacBook2...

I am sure it is possible because the MacBook1's SSD is in APFS and work great on it.

Do you know how to enable it ?

Thanks you !

Answered! View the answer I have this problem too

Is this a good question?

Score 0


You don't need to swap the HDD for a SSD, just run the High Sierra OS installer on the system.


Thanks but i have already done that step.


@yojx21 - You can also compare the EFI versions between the two systems to make sure its at the correct level. Its found under the Hardware Overview section when you click on 'Hardware' header.


They don't have the same EFI version, i don't know which one is more recent... Do you know how to know that ?


Give me your version numbers (both)


Add a comment

3 Answers

Chosen Solution

You have a very simple problem! The disk's format and what the systems EFI can see! APFS Vs Mac OS Extended (Journaled)

Basically your #2 systems EFI was not updated as you didn't install High Sierra on it before switching the drives. Your #1 system with the SSD is now using the newer APFS format as the High Sierra installer automatically upgrades the older HPFS+ partition you had on your system.

If you open up both drives within each in their default setup you can see under About This Mac > System Report > SATA/SATA Express - Content: Apple_APFS on the High Sierra SSD system and your HDD system with have Content: Mac OS Extended (Journaled). You can also see this under Disk Utility as well just under the drives name header in grey.

Apple is now updating the EFI within the OS installer very often these day's, so its more important to upgrade the systems OS. And be mindful when moving drives about.

Was this answer helpful?

Score 0


@danj You are right, my EFI rom isn't up to date, and my MacBook1's SSD is in APFS format.

Here is how i solved the issue.

* In the MacBook2, i have installed another spare SSD i was having.

* I have formated it in Mac OS Extended (Journaled).

* Then i installed macOS High Sierra on it.

* Once High Sierra was set up, i downloaded High Sierra upgrade from AppStore and ran it.

During the installation, my EFI rom was upgraded and now i can boot MacBook1's SSD !

Thanks you everybody for your help!!


Add a comment
Most Helpful Answer

Did you try to use the HDD from MacBook 2 to MacBook 1? It should work in theory.

If all does not work you might just need to reinstall the OS on the Macbook 2 with the SSD in it.

Was this answer helpful?

Score 1


No need for swapping the drive to SSD to install the needed EFI firmware to support the SSD's APFS partition, just upgrading the HDD with High Sierra will do it.


Add a comment


I would suggest installing Sierra first until you overcome the bootable SSD issue, then upgrade to High Sierra after. Feel free to follow the steps below, I can't guarantee as I don't know the true cause of your SSD not being detected, but they should work for most common issues.

1. On MacBook2, Try to install MacOS Sierra 10.12.6 combo update through Apple's website,

2. Connect the SSD in question to MacBook2 and format it with HFS+/GPT option; if you're on High Sierra and you only have an option of APFS then use Terminal app; enter "diskutil eraseDisk HFS+ %noformat% diskidentifier" make sure you use correct disk identifier of your SSD to be formatted (use disk utility app or "diskutil list" command in terminal.

3. Partition your SSD.

4. start the installer which you initially downloaded from apple website. When you get to the option to select destination drive, select your SSD; this method can work, but I haven't tried it. Follow next step if this presents any errors.

5. Restart your computer from apple menu, and press Command (⌘) – Option (⌥) – R combination immediately upon hearing the startup chime. Hold the keys until the animated globe appears on the screen. “Starting Internet Recovery,” the message reads. ”This may take a while.”

6. From here on just select the correct WiFi unless you're on ethernet, this will restore the recovery partition in this drive; just follow the disk utility in there to reformat the SSD and reinstall the OS (you can make the selection based on choices presented). After you are finished move the SSD to MacBook1 and you should be good to go.

7. You could also put the SSD into MacBook1 right after Step 4, as correctly formatted and partitioned drive should be detected.

Just so you understand that the EFI folder resides within your SSD, as from your initial comment it seems that your understanding is that EFI folder is detached from the bootable SSD; it's not. Also, there are couple other ways you can fix the issue; like backing up a working image from MacBook2 and restoring that image to this SSD. But if this works then you'll have an independent OS from beginning. Hopefully it works for you.

Good Luck

Was this answer helpful?

Score 1


@yojx21 needs to install High Sierra as the Sierra OS installer won't update the EFI to the needed release to support APFS. What happened is when he updated his SSD system with High Sierra behind the scenes the drive was updated from Mac OS Extended (Journaled) to APFS! You can't stop it when you have a SSD. The OS installer won't alter the older HDD drives format only when it see's a SSD.


Add a comment

Add your answer

Yohan will be eternally grateful.
View Statistics:

Past 24 Hours: 3

Past 7 Days: 21

Past 30 Days: 77

All Time: 124