Skip to main content

Repair guides and support for motherboards and CPUs.

137 Questions View all

Asrock z77 motherboard doesn't turn on, PSU does

Hi,

so I've got an issue where my ASrock z77 extreme 4 doesn't turn on - when I press the power button/short the power pins the PSU turns on but the motherboard doesn't (judging by the lack of post beeps & cpu fan not turning on)

I've got no GPU connected and I've got two 4gb ddr3 sticks plugged into it in dual channel. I'm really clueless and trying to narrow down the problem. There is a possibility the cpu is dead but I'm not sure, don't want to buy a new one until I'm sure it's the CPU at fault.

Also if anyone happens to have this motherboard I'd greatly appreciate a picture of the backplate of the lga1155 socket as I've found an smd capacitor that was sticking out (not soldered to it properly...) so I just broke it off - the capacitor wasn't connected anyway and appears to have been like that from the factory (could it be that..?)

https://imgur.com/a/ijDwn

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

If your computer is running slower than usual, randomly freezes or restarts, or refuses to boot, see the Motherboard Has a Faulty Capacitor problem page for capacitor troubleshooting help.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Eric A. Nedved will be eternally grateful.
View Statistics:

Past 24 Hours: 2

Past 7 Days: 3

Past 30 Days: 4

All Time: 205