Skip to main content

Model A1106 / 1280x854 screen resolution

89 Questions View all

PowerBook G4 1.5-1.67 GHz won't boot or charge the battery


I'm using a Powerbook G4 15" 1.67 GHz. Last week I was using my computer as normal when it suddenly shut down. The battery was dead, and the charger had a reputation for being flaky, so I reattached it. It booted, but then the reserves on the battery ran out of power and it died. The light on the power adaptor then went out.

Upon trying again, and again, it worked, but with shorter and shorter battery lives. Now the batteries are completely dead. It won't charge the batteries.

I replaced the battery and the charger with no luck, and I've replaced the DC in/sound board. The symptoms are the same.

If run with no battery then the machine makes the brief whirring at the beginning as it spins up the HD, but then it turns the fans on and doesn't turn them off. The screen remains black.

Is there anything I can do?

If not, there's a lot of data on there which I'd like - how can I either:

i) kludge some sort of battery simulator which will provide continuous power to the battery port (I am 100% certain that it runs fine off battery)

ii) Charge the battery externally (I don't have access to another Powerbook G4, at least for the time being)

iii) Get the HD out and read it with another computer?

I can't afford to send it off for data recovery, and since it's out of warranty I can't afford an apple repair either (I think they won't do it anyway, since it's a legacy product)

Any help is much appreciated - I'm getting kinda desperate here :S


Answered! View the answer I have this problem too

Is this a good question?

Score -1
Add a comment

4 Answers

Chosen Solution

Your data is almost certainly safe. The hard drive only needs to be hooked up to an adapter or put into an external enclosure. First remove the battery and charger and press the power button for 10 seconds. Replace the battery and adapter and let it charge for an hour. Start up holding down the Option - Command - P & R keys and hold for three tones. What color of light are you getting on the AC adapter? Here's a Universal adapter:

Here's an external enclosure with the benefit of being firewire so you can boot from it: [linked product missing or disabled: IF107-072-1]

Was this answer helpful?

Score 4


Mayer, you are a god amongst men. Thank you SO MUCH!!! I'll try the charging trick you said and let you know how it goes.

When I plug the adapter in, it is green. If I start the computer with no battery, it goes orange, and stays orange whilst it whirrs away like a squirrel with a chainsaw as I described in the previous post. I can't say what it does with the battery as both are completely dead now.


Update: I plug it in and it goes green, then orange. The first time I tried it it then went off, and I had to unplug it at the wall and plug it in again to get it to work, but it seems to be staying orange now.


Update: failed the charging thing, since it didn't charge the battery. Any other things I could try? It would be nice to have around as a backup computer...


Well that was a short hour. Remove the battery, leave the AC adapter plugged in and see if you can zap the PRAM (key combination)


%#*!^@, clock must be wrong. Anyway, it was plugged in all day today with no avail. When I try and start it acts as if there's no battery in there (an since the battery is completely dead, who can blame it?) which involves the squirrel chainsaw noise I described earlier, so it doesn't get far enough in the boot to do anything. If I can get it running from the battery port, I could zap the PRAM, but I can't since it won't charge it. From memory, I think I did try that last week while there was still a bit of charge in the battery, but I can't be sure.


Show 5 more comments

Add a comment

I would try replacing this cable, it connects the Logic board and the DC-in board.

Apple will repair it, though if it is out of warranty it will cost you a fortune.

If you were looking for an upgrade anyway, you could put your hard drive in a new computer following this guide. Good luck, let us know how it goes.

Was this answer helpful?

Score 1
Add a comment

Thanks for the prompt response. Do you reckon the logic board is dead?

And I have a brand new computer now, (YAY) and the issue is getting the data off it... I simply don't have the money to repair it.

Is it dangerous to test the cable output with a multimeter whilst the charger is plugged in?

Was this answer helpful?

Score 0


Sounds like it was running with the exception of poor power levels. The logic board should be fine when you have the cash to repair it. I'd try using an adapter to get your data onto your new computer. Here's the one I use:


Thanks Mayer. I got my data off no problem and I'm going to send it in for repair. Thanks for your help.


Add a comment

Have the same problem , PowerBook G4 17"

After days of not using it , now its not starting .

Black Screen and unlock button acts like the computer is on sleep mode ...

Had updated it to Leopard previously . Now its just black screen with drive and fans noise ...Tried all key combinations.

Even during charging , only orange light.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Dylan Auty will be eternally grateful.
View Statistics:

Past 24 Hours: 10

Past 7 Days: 10

Past 30 Days: 13

All Time: 6,013