MacBook Pro exposed to reverse current

Ok, so, my Macbook charger Magsafe 1 60w started having problems (the magnetic part separated from the head of the charger, it started sparking and it worked putting the piece back in place till I lost the magnetic part. In that moment the Macbook was still working till the battery drained out) so I decided to change the cable. I opened the Magsafe and I found two soldering points where was the cables. I replaced the old cable with a new one, but when I soldered the cables, I soldered the white cable where I must have soldered the black one exposing my Macbook to inverse current. I connected the charger to the wall and my Macbook didn't charged and the Magsafe Led didn't switched on. I started hearing weird sounds coming from the Magsafe circuits and I dissconnected the charger. Then I realized my mistake but I just decided to buy a new Magsafe charger. When I connected the Magsafe, LED didn't switched on, didn't charged and my Macbook still unusable. I want to know: is there any protection like rectifiers inside the Macbook's DC Power In? If there aren't my Macbook's Logic Board is dead? Should I change the DC Power In module? I has seen the Magsafe Board (Macbook's DC In) and it seems like there is some kind of SCR or MOSFET burnt. The logic board seems to be ok.. Thank you very much.

Answered! View the answer I have this problem too

Is this a good question?

Score 2
Add a comment
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12

1 Answer

Chosen Solution

@skoxx start by replacing the DC-in board using this guide MacBook Pro 13" Unibody Mid 2010 DC-In Board Replacement The replacement part is available from here MacBook Pro Unibody 13" and 15" MagSafe DC-In Board After that re-evaluate and let us know what you get.

MacBook Pro Unibody 13" and 15" MagSafe DC-In Board Image

Product

MacBook Pro Unibody 13" and 15" MagSafe DC-In Board

$24.99

Was this answer helpful?

Score 2

Comments:

I will buy it and in two days I will change it. After that, I will come back to do a feedback.

by

So... I changed the Magsafe board and still not working. I don't even get a light from the LED.

by

New update. I decided to test my charger under different environment and I realized that the adapter's fuse was burnt (yes, maybe a problem with the old charger) so I took another adapter and everything is working right now. Thank you very much, I know that we are stronger than broken B) We fix it.

by

Add a comment

Add your answer

Sebastian Ortega will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 5

All Time: 128