External storage options by Seagate, usually connected by USB, available in many storage sizes and form factors.

33 Questions View all

Plugged in to computer but isn't being recognized, not in disk utility

I have a MAC. I had my Seagate 1tb Backup Plus Slim Portable Storage device plugged in a few days ago, and all the sudden the message popped up that it was "improperly ejected" even though it hadn't been touched or anything. I tried to replug it back in and the LED light will come on but my computer won't recognize it.

It has a small click noise and is working but it isnt a loud click like the "click of death"

Also I already tried the trick in finder where you make sure external drives show up and checked disk utility- no luck!!

PLEASE SOMEONE HELP!!

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Mac RAM Kits
Speed up your Mac. Max out its memory.
Mac RAM Kits
Get more memory out of your Mac.

2 Answers

Chosen Solution

Could be the drive or the enclosure. First thing to do it put the drive into a new enclosure.

Was this answer helpful?

Score 1

Comments:

Maybe it's just the SATA bridge? Apparently they are notorious for breaking.

by

Add a comment

I just watched a YouTube video from the author of this webpage. https://discussions.apple.com/docs/DOC-6...

https://m.youtube.com/watch?v=5cTZBMi-Xw...

Was this answer helpful?

Score 0
Add a comment

Add your answer

Jacqueline Fugatt will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 3

Past 30 Days: 9

All Time: 81