Announced in March 2015, and released April 10, 2015, the Galaxy S6 is the next flagship in the Galaxy line. The curved screen version is known as the Galaxy S6 Edge.

316 Questions View all

Stuck on Samsung Boot Logo

All I get for booting up the phone is:

'Samsung powered by android'

What I have tried:

- Letting the phone charge up for a while

- Reflashing firmware on the phone, correct matching to the serial number of the phone by checking via Samsung Smart Switch

- Booting recovery, does not get into recovery, stuck on logo again.

A couple of questions:

- There are no signs of the phone showing symptoms of DRK (Device Root Key) being damaged, I would prefer not to trip the KNOX warranty from flashing custom binary unless I need to. Like custom kernel to check DRK if it's bad or custom recovery to see if it will boot that

- I know that a bad battery can cause this (but this time it's not actually bootlooping, it's stuck on the logo), should I try an replacement battery? I got one on hand, but if there's anything else I can try before I try this I would appreciate it a lot.

Note that the battery actually does hold charge meaning that there is a lower chance of it being the battery at fault, the last time I had to replace a battery to fix bootloop was because the cable to the battery was partially damaged.

Answer this question I have this problem too

Is this a good question?

Score 1
Add a comment
New Battery = Faster iPhone
Fix Kits starting at $16.99

2 Answers

Most Helpful Answer

What is the longest time you let it sit at the logo?

What model number does your phone have?

The flash you attempted, was it lower or higher than what was on the phone already? You may have to flash it with the latest Android, then side load the latest security updates. The new thing with KNOX is that your phone will sit at the boot logo if you flashed to downgrade.

Also, I noticed you didn't say you cleared/wipe cache/ dalvik and factory reset in recovery. I am assuming you did, but you didn't list those steps?

Was this answer helpful?

Score 1

Comments:

I've tried letting it sit on the white Samsung static boot logo for about 30 minutes, the phone would just heat up as it's stuck there.

SM-G920I, the flash I attempted was the latest one for the model, 7.0, it's either identical or higher than what was on the phone already.

I tried to boot recovery but it would not let me, it would just hang on the Samsung logo.

I just tried another battery now, unfortunately still on logo even after unplugging charging port, earpiece speaker, back camera and rear camera.'

No signs of liquid damage after quick inspection of the board.

by

If the phone is heating up, sounds like either a bad flash or a bad component somewhere on the logic board. Since you changed the battery, that has been ruled out. You said you can't get to recovery, but can you get back into download mode? I would get another factory image from XDA if you got it from somewhere else.

Also, when looking for a rom, look for one with a similar baseband. This should be listed on the back of the phone or a box. It looks like this: "G920IDVU1AOD1".

by

Turns out bad component on the logic board, I used old version of Samsung Kies to detect correct region firmware for the phone via serial number input. (Sammobile and Updato is where I get my firmware)

Looks like this phone is pretty much as good as a doorstop.

by

Well reselling the housing, camera, and display assembly can help recoup some loss, I hope.

by

Add a comment

Hy , i have this probblem and i solved , i root my phone with Odin , if this not work you can add a TWRP Custom Recovery, and then it will work ,

Was this answer helpful?

Score 1

Comments:

I already tried TWRP custom recovery, the phone is very badly bricked in a way, worse than DRK damaged.

Custom recovery doesn't boot. Thanks for the answer though.

by

Add a comment

Add your answer

Ben will be eternally grateful.
View Statistics:

Past 24 Hours: 2

Past 7 Days: 20

Past 30 Days: 71

All Time: 111