Guides and support for various TV brands and styles.

2754 Questions View all

Panasonic TH-L42ET60A TV has sound but no picture

TV has no picture, but has sound. When tv is turned on it has a faint light to it (appears to be LED backlight). Have taken rear panel off and connections look fine and has no blown fuses. When TV is turned on has solid green LED illumintaed. Any suggestions?

Update (12/03/2017)

Have looked at all boards and checked fuses and are ok, all connections seem fine and nothing seems to be overly hot when tv is turned on (see pictures)

Block Image

Block Image

Block Image

Block Image

Update (12/03/2017)

@oldturkey03

The fuse is intact, can you elaborate by what you mean about checking pins 1-5 on connector 1?

Block Image

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment
MANTA DRIVER KIT
112 bit driver kit $59.99
MANTA DRIVER KIT
112 bit driver kit $59.99

2 Answers

Most Helpful Answer

Hi Ethan. When you turn the TV on, stand directly in front of it and try shining a flashlight directly at the surface of the LCD panel. Do you see the Panasonic logo or any source image when the TV boots up? It will be very faint. Sometimes putting the flashlight at an angle gives you a better view. If you are seeing an image, your backlight is problematic and your LCD and main driver board are working correctly. The problem can now be 1 of 3 items: The power supply, the LED power driver board (if its separate from main power supply) and the physical LED strips themselves.

Was this answer helpful?

Score 1

Comments:

Thanks Anthony, I had a look with a flashlight but was unable to see any text or logos when turning on the tv, do you have any other suggestions?

by

Add a comment

@ethan1992 remove the back of your TV see and check the boards for any obvious damage. Leaking or domed caps are not uncommon. Check the fuses on the power board, as well as the fuses on the t-con board. You do want to post some pictures of all of your boards with your question. that way we can see what you see. Use this guide Adding images to an existing question for that. AS you've mentioned "has a faint light to it" probably your backlight working but not getting a signal.

Update (12/03/2017)

@ethan1992 there should be another board under the cover on the center bottom of your TV. Let's take a look at that one. Check connector 1 on the LED board to see how much voltage you get on pin 1-5. Check the power on the fuse on the same board as well. Check either side of it and let us know.

Update (12/03/2017)

@ethan1992 I was referring to the voltage on the LED driver board connector 1 "CNT1". Measure the voltage on those pins with your set on. Make sure that you do not touch other points with your probe and measure the voltage. You can use pins 6-10 as ground. Remember this is DC voltage so set your meter accordingly. Also measure the voltage on the fuse on the LED driver board and the T-con board let us know what you get.

Was this answer helpful?

Score 1

Comments:

Checked pins, 1-5 had same DC voltage 23.45V and fuses checked out fine

by

@ethan1992 that sound like the right voltage for the LED driver board. Should now be a toss up between your T-con board and your mainboard. What voltage do you get on the fuse on the T-con board.

by

Appears to be 0.5VDC if I’m measuring correctly (between fuse on T-Con board and ground pins on LED driver board connector 1)

by

Try a different ground see what you get.

by

Every other labelled ground I can find produces same result

by

Show 4 more comments

Add a comment

Add your answer

Ethan will be eternally grateful.
View Statistics:

Past 24 Hours: 32

Past 7 Days: 175

Past 30 Days: 747

All Time: 2,653