4-inch iPhone released in March 2016 with similar hardware specifications to the 6s. Available in Silver, Space Grey, Gold, or Rose Gold with 16/64 GB storage options. Model A1662 and A1723.

207 Questions View all

iPhone SE does not start after reseating power button

Hi,

I started by replacing a cracked screen, all went well, then i realised the power button just about worked but didn't click, so I followed the home button replacement procedure to remove and reseat it, that now clicks and seems ok. Now unfortunately the phone wont power on at all, must have checked everything 5 times.

If I plug into the mains i get nothing, but if I plug it into a PC, iTunes does say you need to unlock "xxx's iphone" before it can access it.

Any advice?

Paul

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Black Friday
Broken doesn't stand a chance.

1 Answer

Chosen Solution

Hi,

If iTunes recognises the phone then the phone works. There are two options here:

  • The screen you replaced is faulty and doesn't show an image
  • The power button you replaced is faulty and doesn't turn the phone on

I would recommend buying a new home button preferably form a good source. I couldn't find any power buttons on my trusted suppliers but there are plenty on eBay. Search up genuine Apple iPhone SE power button flew and there should be some there. Make sure that they are original because they work the best.

Was this answer helpful?

Score 1

Comments:

Hi Tom,

Appreciate the fast response!

The new screen was working as was the power button, the Power button just didnt click/depress do I tried to reseat the original. It does click now.

I tried connecting the old cracked screen which was working but that doesn’t work either so I’m thinking from what your saying the power button may be the issue.

If I remove it completely and plug the power in should it start ? Like a normal working phone does when off and plugged in.

by

I have tried this before on an iphone 5 I think and the phone doesn't boot completely but just shows the Apple logo when plugged into a charger without the battery.

by

Ok, pulled it apart again and it looks like the power button shield was pinching part of what I think was the microphone ribbon so I took the power button and shield out and made sure all was flat and put the button back in, all clicking as before. Except this time when the power via a cable is connected hey presto, it boots! Seems a pinched ribbon may have been the issue, the power button still doesn't work unfortunately, for now I've enabled touch assist so I can lock the screen but at least it works!

Looks like that power button on the SE is part of the shield and separate to the mute, volume buttons etc so should be easy to replace.

Appreciate the advise Tom.

by

Add a comment

Add your answer

Paul Wightman will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 19

All Time: 19