Apple released the slimmed-down, buffed up iPad Air on November 1, 2013 in a choice of Space Gray or Silver. It packs the custom A7 processor and ships in 16, 32, 64, and 128 GB configurations.

382 Questions View all

Stuck in reboot loop

Hi guys, thanks for reading my question!

I've got an iPad Air in a reboot loop. It goes to Apple logo, sometimes flashes red, then restarts.

I've tried freezing it then charging it, it charged a little, but still went back into this loop.

Some background. This iPad wasn't charging, so I cleaned the charge port. I then noticed that the battery screw wasn't done up properly. After a half turn the device started pulling a current.

The data is important and I don't want to lose it.

Also, please post educated responses. If you haven't worked on iPads please choose another question, thank you.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Did this reboot loop occur following some physical impact or contact with water or did it just happen out of the blue? Was this iPad previously repaired?

You said after cleaning the port and tightening the screw that the battery was pulling current. Is that because you have it connected to a USB ammeter? If so, what current was it pulling?

Sorry for all the questions but the more info you share, the more directed my answer.

It is entirely possible that the battery is just dead or dying and not charging properly. It could be a defective charge port (check the internal pins under magnification) or it could be a defective charge circuit (caused when using cheapo chargers and cables) .

Was this answer helpful?

Score 1


Thanks for the response. I replaced the screen on this iPad. Unfortunately didn't screw the battery screw in tight enough. I got it back and the charging was a bit sporatic on the USB Ammeter.

I eventually realised the problem, however now its stuck in this loop, even though its drawing a decent current.


I suspect the variations in charging amperage when the battery wasn't screwed in has fried the charging circuit. That's a complete guess. I did try another battery.

To answer your question about how much current it pulls, it pulls 89ma. I know that's probably less than you would expect however the charge port has a few damaged pins.


Add a comment

Add your answer

Aaron Moffatt will be eternally grateful.
View Statistics:

Past 24 Hours: 14

Past 7 Days: 56

Past 30 Days: 255

All Time: 564