No volume control- headphones or dock

I can't control the volume output of my 1st gen Touch on firmware 3.3.1.

When I plug headphones in the volume slider doesn't appear, reading around I see this was a pretty common issue when people updated to 3.x so I ran a jailbreak and installed SBSettings and the volume slider widget - it doesn't control the volume, still stays at a constant level.

I plugged into the dock and have the same issue - no control over volume from the iPod.

So although I was initially thinking a headphone jack might need replaced I'm not so sure now that when docked it still has the same issue!

Any ideas?

Answered! View the answer I have this problem too

Is this a good question?

Score 0


Just realised you can't control the volume in a dock with the volume slider on any iPod - maybe it is tahat jack needing replaced!


Add a comment

1 Answer

Chosen Solution

I would definitely start with the headphone jack. It is solder on the logic board and is available here and here and the instructions for the logic board are here iPod Touch 1st Generation Logic Board Replacement Good Luck to you and let us know what worked. :-)

Was this answer helpful?

Score 1


Replacing the jack indeed did work - I just removed the ribbon and soldered small jumper cables.


Congratulations, good job and inventive :-) Thanks for accepting my answer.


Add a comment

Add your answer

Neil will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 3

All Time: 3,690