Replaced main board and no picture just music playing

I replaced the main board on my TV and when it turns on there is no picture, just some soft music. I get the green to amber flashing light on the bottom remote control sensor on the TV. I tried putting a thumb drive with the latest update in the usb and still nothing after several hours.

Thanks For you help

Update (09/25/2017)

Lets start from the beginning, We were watching tv and switched the HDMI input to the one our apple tv was hooked to and watched that for a bit. We switched back to the cdmi that our Directv was hooked to and got a message on the sony home screen(something to the fact that had quit responding). We tried to select another input and this msg would just keep coming up. We then unplugged it and let it sit for about ten min then plugged back in, it came up with the "Sony" screen, then went black, and then went to a black screen with the light around the edge. Couldn't get any buttons to work now. We then unplugged and let sit overnight and plugged back in in the morning with the same results. I called Sony, no help there, then called Best Buy talked with Geek Squad member and he advised me that is was prob a main board(BTW Tv is only 16 months old). So I found a main board on eBay part # A-2072-588A , the main board part# that came out of tv was a A-2072-588B.

Update (09/25/2017)

Now I have a black screen no "Sony" booting up, led is flashing between amber and green, and just some soft music. I can cycle it on and off with the power button now and it will just go to the white led but still no picture.

Thanks in advance

Answer this question I have this problem too

Is this a good question?

Score 0

Comments:

I'm having a similar issue with my Sony Bravia XBR-65X850D. My HDMI inputs stopped working after a power surge, so I bought a replacement main board. After installing the new board, the indicator light flashes green and amber for maybe 0.5 seconds each. It will do this indefinitely until I press the power button on the remote, which turns the light white (no other changes in behavior… still no picture or backlight). I know I need to update the firmware since it's a new board, but I can't do so without any display. I know none of the other components are faulty, as reinstalling the old board restores all functionality. Is this simply a faulty replacement? Or is there some step I've completely missed?

by

I’m having the same exact issue ! On a 850c. Same symptoms after replacing the main board. Did you find a solution to fix it ?

by

Add a comment

Free shipping on all orders over $100 or containing a Pro Tech Toolkit!

Browse Our Store

3 Answers

Most Helpful Answer

@tweed6 let us know if that LED blinks with any sequence. When you say you changed the main board are you referring to the Main board (all the inputs are on this board) or the Power board. Since you have sound but no picture it could be the power board not turning on the backlight or a failed T-con board. Post some images of all of your boards with your question so that we can see what you see. Use this guide Adding images to an existing question for that. the T-con board should have a use on it as well as the fuses on the power board need to be checked for continuity.

Was this answer helpful?

Score 1
Add a comment

I ended up finding out it’s a bad board. I called for a RMA and the new board arrived. Once I replaced the new board I was able to get some lights to flash which was white and green. I pluggedin the a USB with the latest firmware downloaded from the sony site and it took about 30 mins for the update to take place and a few restarts.

It restarted into the Welcome screen and everything started working perfectly afterwards.

Was this answer helpful?

Score 1

Comments:

I ended up finding out it’s a bad board. I called for a RMA and the new board arrived. Once I replaced the new board I was able to get some lights to flash which was white and green. I pluggedin the a USB with the latest firmware downloaded from the sony site and it took about 30 mins for the update to take place and a few restarts.

It restarted into the Welcome screen and everything started working perfectly afterwards.

by

When you say bad board are you referring to a bad main board?

I ordered a main board from ebay. It arrived, I installed it and had the green/amber flashing lights, soft music and no picture. I returned the main board and have ordered another one. My fingers are crossed that the second "new" one works. I have the software on a flash drive ready to go.

by

Add a comment

Any further information on this as I am in the same boat?

Was this answer helpful?

Score 0

Comments:

I ended up finding out it’s a bad board. I called for a RMA and the new board arrived. Once I replaced the new board I was able to get some lights to flash which was white and green. I pluggedin the a USB with the latest firmware downloaded from the sony site and it took about 30 mins for the update to take place and a few restarts.

It restarted into the Welcome screen and everything started working perfectly afterwards.

by

Add a comment

Add your answer

Todd will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 10

Past 30 Days: 35

All Time: 587