The second generation of the iPad with Wi-Fi, GSM and CDMA models. Some models were refreshed before the iPad 3. Repair is difficult and requires heat and prying.

866 Questions View all

Certain app not being deleted.

I recently downloaded an app for my iPad 2, However it said i did not have enough memory on my iPad and now it wont go away even when i try to delete it.

Help will really be appreciated.

Thanks

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Can you clear up enough memory to fully download the app and then delete it?

by

I tried that but it doesnt seem to continue downloading.

by

Add a comment
Deck the Halls
With tools and Fix Kits

1 Answer

Chosen Solution

I would try this:

• Connect iPad to Mac or PC

• Launch iTunes

• Create a full backup (do not back up or transfer apps if it asks)

• put the iPad in DFU mode

• install iPad's firmware in DFU mode

• restore from the backup you just made

What this does is clears up a lot garbage files that build up.

It also allows you to manually install apps you want back.

Was this answer helpful?

Score 1

Comments:

Problem is i have not created a backup.

by

I did mention use iTunes to create a backup. in the 3rd bullet point.

by

It worked omg thanks!

by

Add a comment

Add your answer

Cody Rutherford will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 2

All Time: 35