The 5-door Explorer and its companion the Mercury Mountaineer were redesigned entirely for the 2002 model year, gaining a similar appearance to its big brother, the Ford Expedition.

1 Questions View all

My Left High Beam Doesn't Work

I recently purchased my 2002 Ford Explorer Limited and my left high beam will not turn on. So I purchased new bulbs and the left high beam still will not turn on. Then I checked the blue 20amp Bussman female maxi fuse at F1 19 via the see thru plastic cap and the fuse is fine. So I pulled the fuse, checked the 2 flat contact points in the fuse box with my circuit tester with the engine on and grounded to my battery. Only one contact point made my tester light up. How do I fix this problem and did I test it correctly?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Black Friday
Broken doesn't stand a chance.

1 Answer

Chosen Solution

Wiring harness...hopefully...hold on..yeah. This should be it. Shouldn't be complicated

https://www.googleadservices.com/pagead/...

Was this answer helpful?

Score 2

Comments:

This link https://www.google.com/aclk?sa=L&ai=DChc... leads me to a Bluetooth wiring harness. I jus want to kno if both contact points in the fuse box that the fuse attachs to are supposed to make my circuit tester light up? Because if that's the issue then, a new wiring harness will not solve the problem. I don't want to waste money buying unnecessary parts

by

@theimedic get some sleep, you are screwing up.

by

I didn't screw up that time! Google screwed up! @mayer fixed it. He should need a new wiring harness if the readings are coming back that way. Or we'll find another answer

by

@theimedic good boy, you get a cookie ;-)

by

@mayer I like cookies

by

Show 2 more comments

Add a comment

Add your answer

SDarnellC NYC will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 3

Past 30 Days: 17

All Time: 56