Skip to main content

Fix Your Stuff

Right to Repair

Store

Motorola released the Droid Turbo 2 in late October 2015. Model number XT1585.

28 Questions View all

USB connection not working

The data pins on my phones USB don't work so I can't fast charge or use the USB to connect to my stereo. Can it be fixed?

Answer this question I have this problem too

Is this a good question?

Score 4

Comments:

Bought a new phone, Verizon told me it could not be fixed, so after buying a new phone I started to see if someone could fix my old phone. Well I want to thank you for this info, it did work for me and my XT1585 MOTO is as good as new. Thanks again Wade

by

Add a comment

3 Answers

Most Helpful Answer

Have you tried another cable? If so, have you tried cleaning the pins with isopropyl alcohol? I like to use a Q-tip.

Do a visual inspection of the port. It's possible that you have lint jammed in there. A toothpick or tweezers can work to clean it out.

Was this answer helpful?

Score 3

Comments:

I tried cleaning and a different cord it is just the data pins that don't work

by

Add a comment

I had the same problem about 5 times now and Verizon has replaced my phone under warranty. Loose charger port is a “known issue”

Was this answer helpful?

Score 0
Add a comment

My phone started this about three years ago. Internet search found it’s a common problem with the Turbo 2. Port is poorly soldered to the board. Found a company that could repair it. They even had a YouTube video of him doing the repair. Then I found the the phone has an inductive charger, so I’ve been using it ever since. I recently had to replace the battery. Thought while I was in there I’d solder those connections myself. That’s when I realized why he was using a video microscope. The connections are tiny. There are five of them in a row and they are all in about a 3/8 inch space. I had to put on a pair of reading classes and look through the lighted magnifying glass I have mounted on my desk. I didn’t have a soldering tip small enough. In fact I’ve never seen one small enough so I wired a needle to the tip and went at it. The needle just wouldn’t transfer enough heat to melt the solder so I gave up and finished the battery install.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Wade will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 14

All Time: 1,375