UE Boom 2 remote power not working

Hi,

I am using the boom 2 via my iPhone 6s so I have Bluetooth 4.0 support. Yet somehow the remote power on function does not seem to work. I can switch my boom 2 off but when I want to turn it back on again via the app it just gives a standard instruction on how to connect your phone to boom 2.

The remote power function in the setting is turned on by the way.

Any thoughts?

Answer this question I have this problem too

Is this a good question?

Score 4

Comments:

I'm having the exact same issue :(

by

Same issue here, although I am having the problem with my Samsung galaxy s8. Will try on iPhone 7 and iPad air also. Have noticed that when i first turn the speaker off the power button is available in the app for a short time, but it drops out after 30 secs or so

by

Same issue. It turns off and goes to the "let's hook up"screen

by

Same issue here.. Should we all ask for a swap as some previous model used to work?

by

@tidjoz - As it is probably a firmware or app issue, I don't think that would help. But it would be good if we all contact UE support.

by

Add a comment
Deck the Halls
With tools and Fix Kits

8 Answers

Most Helpful Answer

I had the same issue with my new iPhone 7 ,.. iPad Air 2 had no problem with Remote Power on. After

- Removing the app

- Removing the Bluetooth pairing

- Reinstalling the app

- Reconnecting the Boom

My problem was solved. I'm now able to remote power the Boom with my phone.

Which technology makes this remote power available? I've got mulitple bluetooth devices that do not support that feature. Is that a feature from bluetooth 4?

Was this answer helpful?

Score 2

Comments:

Thanks for your answer. I tried this exact approach just now, and it did not work for me. The app just does not show the power on button anymore. Only an instruction. It might be a bug in the app...

by

This one worked for me, I would also recommend a hard reset of both the iphone and the UE boom while you're at it: On iPhone hold home and sleep button until restart, on UE while turned on, hold power and minus button until cloc cloc sound.

by

This did not work for me on my iPhone 6s or iPad 3. I also tried rebooting everything like the above person said before re-installing and connecting via Bluetooth and still have the same inability to “remote on” once I’ve pushed “remote off.” The Boom 2 is listed under Bluetooth settings. I’m able to “remote on” my UE Roll 2, which is also listed under my Bluetooth settings even when off, but sadly not my Boom 2. I have to manually turn the Boom 2 on each time by pushing the speaker’s button after hitting “remote off.”

by

Add a comment

Look at your bluetooth settings within the phone is the Boom2 listed? If not it is not paired with your phone.

I have a iPhone 7+ which will react this way since I've removed the speaker from my phones listing. From within my iPad I can use the app to turn the speaker on or off without any problems as its paired with it.

Frankly, I'm surprised the speaker will even turn on within the app when it's not paired to the phone! FYI: I have my speaker paired with my iPad & MacBook Pro as you can only have two devices sharing the speaker.

Was this answer helpful?

Score 1

Comments:

It is listed, but I can not connect to it, as soon as I turn the Boom2 off from within the app it disappears from my connected devices, which is normal for regular Bluetooth devices.

But there is an option in the app called "remote power" which is supposed to let you turn on your speaker via the app.

I have only paired the speaker with my iPhone and MacBook Pro.

by

What is the list order of the bluetooth devices within Settings > Bluetooth section? Move your Boom2 to the top entry. See if that solves it.

I fully understand what you are talking about, thats not the problem. I use it all of the time with my iPad (yes you can use the app within it's a bit messy as UE didn't format it to be a universal app).

I have my speaker as the first listed and my AirPods listed second.

by

My Boom2 is listed last, since it is the last device I connected to.

How can I change the order of this list without deleting all my previous connections?

by

Within MacOS its quite easy just drag and drop. Within iOS it's a pain! As you found out the order with which you add them in is was sets it.

In my case it just worked out that way ;-}

Are you using iOS 10 or by chance using iOS 11 Beta? I'm using iOS 10

by

Add a comment

I have the same issue. Have a new device to replace my previous one, and the old one had no problem, even if it was at the bottom of the list. New one does not remotely power on at all. Removing all connections except the boom was not a solution.

Update: Ultimate Ears customer service is not responding anymore after repeated emails. I'm opening up a new case, since this is an important feature for me.

Update oct 2017:

UE Service is not responding to emails anymore. I think they gave up : (

My current suspicion is that there is a bug in the app, so that it does not show you the power button. I'm putting this feedback in an App Store review and hope new app update will fix this.

Update 30/11/2017:

UE just launched a new version of the app, and a new firmware version. After updating both, it STILL DOES NOT WORK. Customer Support contacted me again last week, but did not answer to my reply. They have no clue and I'm quite upset right now.

Was this answer helpful?

Score 1

Comments:

@sjors - mmm... I'm starting to think this is a Boom2 firmware issue.

Sjores - As you have two (one working and the other not), can you see if your firmware levels are the same or different between them. I'll check mine as well.

by

@Dan Yes, I think it's a firmware issue. I have the latest version on there (updated last Tue). The other one I can't check unfortunately, because it has been stolen. Hence the new one :)

by

Sorry to hear your Boom2 sprouted legs and ran off ;--{

My UE app is version 5.3.85 and the Boom2 firmware is 2.0.101 Which is working with both my iPhone & iPad correctly.

by

@danj - App version: 5.3.85. firmware: 2.0.101

I've read reached out to UE Support. Their reaction:

" Please specify how and when did you first notice the problem. To identify possible causes, please try the following steps below and inform me of the outcome by replying to this email:

• Unpair and re-pair

• Re-install application

• Update firmware

• Reset speaker

Turn on your UE Speaker. Hold down the volume down button and the power button at the same time until you hear a sound. Your UE Speaker will then turn off.

Upon reboot, it will be on pairing mode

NOTE: You may need to do this more than once if it will not connect upon initial pairing

• Test on another device"

by

@sjors - Sorry I had a typo in my info (fixed now). We have exactly the same App & firmware versions. How odd!

Maybe this issue is related to what firmware you had on it before. In my case I've upgraded a few times, whereas you have what it came with (new).

by

Show 7 more comments

Add a comment

This function always worked for me until the latest firmware update (I have an iPhone 7). Here are the steps I took to fix the issue:

1. Remove the app.

2. Remove the pairing.

3. Reset the UE Boom (hold ‘down volume’ and ‘power button’ until speakers makes a noise, it will then turn off).

4. Download and install UE Boom app.

5. Turn on speaker (when rebooted it will be in pairing mode).

6. Pair phone to device.

7. Test remote power on/off.

Please give feedback.

Was this answer helpful?

Score 0

Comments:

Thanks for your clear explanation. However, this does not work for me. I just tried all of the steps as you described them to me.

The app just does not show the remote power on button - I only see the tutorial screens. So maybe remote power works, but I can't access it. There is no way for me to get rid of the tutorial screens, and I expect that they are hiding the button below it.

This makes me wonder: for other people here with this problem: do you see the button, and it fails to connect? Or do you have the same as me, and don't even see the button in the first place?

by

Everything you said is correct. This is still an issue. I don’t understand how someone with an iPhone 7 can do this. Would love to see it!

by

Add a comment

This didnt work for me. Still no “remote on.” Very frustrating experience with Logitech. Like the guy above, I just see the annoying tutorial screen. I cannot even see the speaker icon that shows if it’s on or off.

Was this answer helpful?

Score 0
Add a comment

I think it is a firmware issue. I just purchased the UE Boom2. I had high hopes for it as I love my UE Roll. My remote power works just fine with the roll, but the Boom is another story. I plan to contact the company for a fix or I’ll be returning for a Bose product.

Was this answer helpful?

Score 0
Add a comment

I've had this issue with a UE BOOM 2 and iPhone SE for months as well. BTLE power OFF was working, but power ON was not.

I've had a support ticket open with UE for many months. Today, they suggested I try the latest 7-Dec iOS app update. I am happy to report that in my case, everything is now working!

I'm using the 6.1.96 UE BOOM 2 app update (7-Dec), iPhone SE (iOS 11.2), and UE BOOM 2 (firmware 2.1.107).

Was this answer helpful?

Score 0
Add a comment

Hah. I've fixed it.

Now I can turn On my boom 2 remotely from the Android app.

Unfortunately I'm not sure how I did it :P

I had the same problem - "Remote On" was set to ON in the settings but when the boom wasn't active in the app there was only an instruction how to pair with the smartphone.

I'dont know if it helps but when you see only the pairing instruction try to slide the app acreen, or try to tapp the screen few times or try to open app setting like then when it's paired to the device. It lookls like the app forgets to show the remote on button, but tapping and slideing helps.

The whole process I've been throught:

I've tried all the proposals that I've found in internet:

1. I uninstaled the app, remove the paired device, I've reset the boom (press - and power until the sound appear) then I've paired it again, installed the app again and..... nothing.

2. so I tried the same process with the second reset option that I've found (press -, + and bluetooth buttons at the same time for ~10-20 sec) and..... tragedy - battery indicator stuck on 20% so again:

3. next reset

4. next bluetooth pair removal

5. even bigger tragedy - I couldn't pair the boom to the smartphone - once It worked but the icon that means in Android that the device is paired was red - the sound goes through boom but the app don't work at all (there is only the instruction how to pair). Few times I got the info that boom 2 reject the pairing attempt. No matter what I do tha pairing is not working.

6 Panic: reset of boom, removeing the app, reset of smartphone, charging the boom and... still nothing - I'm still unable to pair the boom and my smartphone.

7. after a few more attempts I'm back to the red icon - now the boom plays the music but the app does not sees it at all and pressing + and - returns the information about 20% charge. I thought that I mess something up.

8. I've resigned - I've disconnected the boom from the charger and I've tried for the last time to check if boom still plays the music and... the icon is not red anymore!

I installed the app once again - it sees the boom and the battery is back to 100%!

9. Happy that I'm back to the place I've started from. I restored my equalizer settings, changed the name of the boom 2 to my personal one, little afraid but I'm checking if I can still turn the boom off remotely. The boom2 goes off and... instead of pairing instructions there is a button to turn it remotely on!

10. As you can see the process was not pleasent. I even thought I mess something up! The final result: All the things that worked earlier, still, works. Ue is connecting to my smartphone with no problems, Ue app works normally, the battery is returning real values instead of 20%

11. Remote on is not the best one because sometimes there is a button to switch in on remotely, sometimes only the instruction how to pair.

But since I menaged to restore this option for the first time, now I can always force the remote on to work again: When there is no remote on button but only the instruction, I'm trying to slide the scrren, trying to open app settings and so on and it always helps now.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Ruud Bloemhof will be eternally grateful.
View Statistics:

Past 24 Hours: 48

Past 7 Days: 493

Past 30 Days: 2,276

All Time: 5,041