Skip to main content

Lenovo IdeaPad, Yoga Series. Released October 2013, 13.3 inch screen, 8 GB RAM, 2 GHz CPU, 512 GB SSD.

16 Questions View all

Did my TouchPad die as a result of upgrading SSD?!

I just upgraded my SSD using the iFixit guide for that ... now I am having exactly the symptoms described in the support question "Is my Lenovo touchpad broken?" which is the TouchPad lets me scroll but both buttons fail to let me select. Since it was working immediately before, and not working during my restoration of the System Backup Image ... well I have to conclude that somehow it is related.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
1 Comment

Hello Jo,

Have you tried updating the Drivers for the touch Pad?

Regards

Ricardo

by

Add a comment

3 Answers

Chosen Solution

Hi all --

I appreciate all the suggestions -- took me a few days to get to it : the Pacific Northwest is having a heat wave, and I had some preparation to do -- and NOW is a good time to stay indoors and work on my computer!

I took it apart again, however somewhere in between I read (I think in the Lenovo Yoga2 Pro hardware manual) about the torque requirements for the various screws. I did not find anything damaged or not fully connected -- however, using the proper torque on the screws on reassembly, everything works again! hopefully this will help someone else!!

-- Jo D

Was this answer helpful?

Score 0
Add a comment
Most Helpful Answer

Sounds like either you damaged the cable or simply just didnt plug it back in properly or all the way.

I suggest taking it back apart and just unplugging and plugging back in the cable making sure its pushed in all the way.

If you try that and it doesnt work, let me know and we can explore other options

Lenovo Yoga 2 Pro Trackpad Replacement

If you look at step 4, the trackpad cable is the one directly to the left of the battery connector.

And does it work fine with a mouse?

Was this answer helpful?

Score 1

1 Comment:

yes it works fine with a mouse.

I haven't tried anything yet - so taking it apart for a look seems first, checking for updated drivers sounds second.

by

Add a comment

I'm with Cameron sounds like the ribbon cable for the touch pad is not plugged it completely. Could also be drivers since you had to reinstall windows on the ssd. Check device manager and see if its there under mice and other pointing devices.

Was this answer helpful?

Score 1
Add a comment

Add your answer

jo diamond will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 17

All Time: 326