couldn't access the bios?

Hello everyone i am trying to fix my acer aspire v5-431 but i couldn't access my bios to format it i have tried everything else mention over previous threads but nothing worked for me..!!All it does is starts with acer logo and after a while suddenly gives blue screen death issue.i have attached few images any help would be highly appreciated thank you!

Block Image

Block Image

Block Image

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

Free shipping on all orders over $100 or containing a Pro Tech Toolkit!

Browse Our Store

Ever fixed something? That’s Genius.

Share your repair story with #ImAGenius

We Are All Geniuses

Share your repair story with #ImAGenius

1 Answer

Hello

Try to remove the battery for 30 mn then put it back switch on and see if is okay

Was this answer helpful?

Score 0

Comments:

you mean bios battery or power batter?

by

Add a comment

Add your answer

Krishna Shakya will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 6

Past 30 Days: 24

All Time: 524