Released June 2012, Model A1278. Intel processor with Turbo Boost, Up to 512 MB DDR5 Video RAM

787 Questions View all

No power, dim green/orange on magsafe mbp 13 mid 2012

Hi, i have a mbp 13 that not doing anything, no power, no fan, no battery indicator, i try everything like disconnecting the bat, push the power for xx seconds, i charged the battery in other mbp, put it back and still without respone (only 1 time the magsafe green light got blinking bright but then started to dim and back how it was before)

So i don't know what to do :(

Edit: i was checking some voltages and it doesn't look very good, also some times i can hear a ticking noise coming from the logic and its in the same time that the orange light flicks in the magsafe connector

820-3115-b

PPBUS_G3H, 9.51v

Pp3v42_g3h, 0.11v

Pp5v_s5, 4.92v

Pp5v_s3, 2.66v

Pp3v3_s5, 0v

Pp3v3_s3, 0v

Smc_bc_acok and ADAPTER_SENSE not present

Chgr_acin 0v

I have checked other voltages butni dont have here right now

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Black Friday
Broken doesn't stand a chance.

1 Answer

Chosen Solution

After you charged the battery up in the other machine, did you check it with Coconut Battery or other APP to see how much of a charge it actually has?

http://www.coconut-flavour.com/coconutba...

With the new battery in does the battery test indicator show anything?

Disconnect the battery and Mag-Safe adapter. Then reconnect both and you should get a spontaneous reboot.

Was this answer helpful?

Score 2

Comments:

I didn't check with coconut battery but the other mbp was working good with the magsafe disconnected, intry disconectect bat and mag, recinect both and nothing happend, only the dim green/orange light flicking in the magsafe conector, i checked some voltages in the logic and it doesn't look good

820-3115-b

PPBUS_G3H, 9.51v

Pp3v42_g3h, 0.11v

Pp5v_s5, 4.92v

Pp5v_s3, 2.66v

Pp3v3_s5, 0v

Pp3v3_s3, 0v

Smc_bc_acok and ADAPTER_SENSE

Not pressent

Chgr_acin 0v

I have checked another voltages but i dont have here now

I don't know where to start

by

That's not supposed to happen. Please give us a complete history of the machine, Spills, repairs, upgrades or other changes. Plus were there any warning symptoms ?

by

I bought with these problem, it says that it was water damage, but i didn't find anything wrong in visual check, but i put the logic in isopropilic alcohol, clean everything, dry and plug.. and thats all the history that i know (sorry for my English)

by

Add a comment

Add your answer

Nicolas will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 2

All Time: 74