Skip to main content

A rugged chromebook designed for educational use with reinforced ports and hinges, anti-peel keys, a sealed touchpad, and 9.5 hours of battery life.

6 Questions View all

Why won't my touchpad respond?

I can turn on the laptop and use the keyboard but every time I try to move the cursor around it still doesn't move. Once in a while if i keep trying I may get a very slight movement.

Answer this question I have this problem too

Is this a good question?

Score 2
1 Comment

Student Question


Add a comment

2 Answers

I had this problem too. Your touchpad is most likely partially disconnected inside the device. I fixed it easily by opening up the Chromebook and reconnecting the touchpad to the motherboard. This can happen when your Chromebook experiences a drop or a hard hit.

Was this answer helpful?

Score 1


So you guys joined the site the same day and join the same 4 man group, post about the same device and comment on each others posts?

You guys just really into the N21 or is there another angle here?


Hi @thethirdtwin ,

They may be students doing projects under the auspices of ifixit, learning how to answer technical questions.

That is usually the case when you see schools mentioned in their profile

When I notice that I leave the answering to them unless it is totally wrong ;-)

You may also notice that the moderators leave a comment of 'student question' if they spot it first


I figured as much, but they're answering each other questions which I thought was weird. But if you've seen this before I'll leave them to it.


Fair enough.

I only take more notice if they don't have a 'school' mentioned in their profile (which can happen) and if their answers make no sense at all, are totally misleading even malicious, are rude etc etc.


@thethirdtwin yes those are indeed students. You can easily identify them by clicking on their "avatar" where you notice that their team is "Cal Poly, Team S21-G2, Livingston Spring 2017" Anytime you notice weird things like this, double check. If they are not students, then you know we'll deal with it. Thanks for being vigilant


Show 3 more comments

Add a comment
Most Helpful Answer

Can you click it down? If not the screws may be too tight. Also try powerwashing it as it could be softwere. As a last resort and the most likely cause open it up. The ribbon cable probably wiggled loose.

Was this answer helpful?

Score 1
Add a comment

Add your answer

Andrew Luong will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 5

Past 30 Days: 10

All Time: 2,450