Model A1013, A1052, A1085, or A1107 / 1440x900 screen resolution

150 Questions View all

replacement UJ-875S reading only DVDs not CDs

I've just replaced my dead UJ-816-C with a UJ-875S superdrive. The drive is reading DVDs fine, but will not read CDs of any type. Oddly enough it will accept a blank CDR and burn to it. However, it rejects blank DVD-R media. I get the typical sounds of it trying to read and then it ejects the disc. I have gone though all the typical system resets (PRAM, caches, etc.) with no difference resulting. Likewise, I have tried the firmware DATs posted on rpc1.org for this drive. Any other ideas?

Here are the details from the system profiler:

MATSHITA DVD-RAM UJ-875S:

Firmware Revision: 1.01

Interconnect: ATAPI

Burn Support: Yes (Unsupported)

Profile Path: None

Cache: 2048 KB

Reads DVD: Yes

CD-Write: -R, -RW

DVD-Write: -R, -RAM, -RW, +R, +RW, +R DL

Burn Underrun Protection CD: Yes

Burn Underrun Protection DVD: Yes

Write Strategies: CD-TAO, CD-SAO, DVD-DAO

System Software Overview:

System Version: Mac OS X 10.4.11 (8S165)

Kernel Version: Darwin 8.11.0

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

I finally had to give up and buy another drive. I got a MATSHITADVD-R UJ-825. This works fine. The other one just doesn't seem to be compatible in reality.

Was this answer helpful?

Score 0
Add a comment

I have the same problem. Bought and installed a UJ-875S in my powerbook G4 1.67 GHz 15-inch. It plays DVDs, but not CDs. I'm running leopard 10.5.8, and have even tried completely reinstalling the OS. Same problem. Been searching the web and seen this post and one on the apple forums with the same problem, but no solutions.

Was this answer helpful?

Score 0
Add a comment

Add your answer

gaijin will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 1,387