MacBook Pro models with 13" displays

4804 Questions View all

I need to remove a DVD from the DVD player.

I have tried 5 or 6 solutions and no luck. it sounds like it is trying to eject but stops in the middle of the process. At this point I would just like to get the DVD out.

Thanks in advance for your help.

Laurie

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Hi Mayer, Yes I have tried the terminal command, holding the keypad down on a restart, also holding the eject button while restarting, and talked to Apple Care who told me to take it to a 'Genius' at one of the stores. I did do that but they wanted to charge me 'my first child'! So I am going to go the iFixit route and see if I can do it myself. So thank you for your suggestions. Happy Day!

Laurie

by

If you tell us your exact model we can get you to the correct guide.

by

MacBookPro 13" early 2011 with 500 GB hard drive running Sierra 10.12.4, A couple of months ago it was making a sound like a motorcycle! I left it alone for a few days waiting for a genius appt. When I took it in the noise quit. Took it home and then to work the next day. Played a video for my class and it wouldn't eject. I became worried as the last PowerBook just quit working. I could only recover 70% of the data. Now I have a backup. I learned my lesson! So I went out and picked up a new 13" MacBook Pro 2016, Four Thunderbolt 3 Ports. I like the power of the new one however I miss my old clunker, especially not having all of the adapters to fiddle with. Any way I will get up the nerve to tear it down and get a new DVD drive. Thanks for all of your help.

by

Add a comment

1 Answer

Chosen Solution

Laurie, I have no idea of what your 5 or 6 solution were, nor am I going to sit here for an hour and tell you things you already know about. Please tell us what you have tried, then we can know what you haven't.

Meanwhile try this:

Open the Terminal in the /Applications/Utilities/ folder and run:

drutil eject

Alternatively, restart with the mouse button held down.

You may have to open it up if all else fails and open the optical drive.

Was this answer helpful?

Score 2
Add a comment

Add your answer

Laurie Graham will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 1

All Time: 31