Broken Disk Drive Dataport

I've bought a defective PS4, the disk drive accepts disks and spins them, but the Eject button is completely unresponsive. The disk does not show up in the main menu.

So I took a look at the data connection between the drive and motherboard and it seems that the previous owner ripped out the data cable and broke of the top part of the connection port. The pins inside the port seem to be fine and i can slide in the data cable, but my concern is that the missing top part of the connector doesn't push the cable onto the connectors. Could that be the problem?

Here are some photos of the connector:

Cable connected

Cable unplugged

I've also switched the whole disk drive with a working PS4, the drive worked there (eject button etc.). Also tried switching the data cable, didn't make any difference. So it has to do something with the connection on the motherboard.

I'm glad for any help

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Thats the issue. Try holding your finger down on the connector and see if it then works. If it works you need to replace the connector. its pretty broken and not fixable unless your good at micro soldering. You could try putting some duct tape on it to hold it in place. That tape would be the best option to make it work.

Was this answer helpful?

Score 1

Comments:

Thanks that worked. I had to bypass the power supply to hold my finger on the connector to see how much pressure it needed, then I put tape over the connector to press it down and its working.

by

@matze_00 Glad it worked

by

Add a comment

Add your answer

Saiht Tam will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 23