Repair guides and support for 27" Intel iMacs by Apple.

1381 Questions View all

2011 iMac shuts down few seconds after power on

My 2011 27'' iMac had a graphic card problem (vertical lines on the screen)

I took the opportunity and upgraded the card from 1gb to 2gb.

When I turn on the mac it start to boot and suddenly shuts off

I can turn it back on again and it happens again and again.

I tried to make NVRAM Reset and it didn't help.

I took out the power cord from the mac, waited few seconds, pressed the power button for 10 seconds, then, I pressed the power button and hold while putting back in the power cord and powered on the iMac.

the fans started to run at full speed and the iMac is running good and stable without shutting down but the fans running at full speed.

i made a SMC Reset, the fans started to run normally but the problem appeared again and the iMac shuts off.

#1 led is turned on while the iMac is turned off

  1. 1,2,3,4 lets turned on after few seconds

after the iMac shuts off #1 led is the only one on

i made an hardware test while on "safe mode" (fans at full speed) and i got error code: 4VDC/1/40000003: VIDEO CONTROLLER

any advice?

Thanks in advance

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Either you got a GPU card that doesn't have the custom Apple firmware. Or, its' defective. You'll need to return it and locate the correct part which is this:

  • AMD Radeon HD 6970 with 2 GB of onboard RAM - Apple P/N: 661-5969

Was this answer helpful?

Score 2

Comments:

Hi Dan,

Thank you for your fast answer.

The card was removed from an 27'' 2011 iMac.

I checked "about this mac" and confirmed that the graphic card that is writen there is AMD Radeon HD 6970 with 2 GB.

if it wasnt with the custom apple fimware was it writen also?

and as I said, in "safe mode" the mac is running good but the fans are at full speed.

I downloaded temperature gauge to check if its running hot but when its on "safe mode", its unavailble.

I also tried to catch a second to look on the temperature on "normal mode" before it shutting off and didnt see any abnormal temperature

by

@aviad259 - The error code '4VDC/1/40000003: VIDEO CONTROLLER' Is telling me the card has problems.

The high speed fan is likely do to a faulty thermal sensor (which could be within the card) Double check your connections. One of the connectors has a SMT resistor just in front of it which you can snap off if you're not careful on the main logic board near the CPU. But that won't cause the error you have here.

by

Add a comment

Add your answer

Aviad Mazal will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 3

Past 30 Days: 4

All Time: 83