Entry level laptop introduced in 2015. Comes in a range of processor options from the Celeron to the Core i7. Also comes with a few AMD processors, but most are Intel based.

35 Questions View all

Synaptic touchpad not working

My touch pad does not work, driver not showing in device manager. I downloaded driver from Acer, it told me it was installed and ready for use, but still not in device manager,neither can I find where it installed. I also did a complete system restore, Any ideas please.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Black Friday
Broken doesn't stand a chance.

1 Answer

Chosen Solution

Hi

Have you tried pressing Fn + F7 together to 'toggle' the touchpad back on? (Fn + F7 turns the touchpad both On and Off)

Where did you check in Device Manager, was it under Mice and other pointing devices?

Also have you checked in Control panel > Mouse to see if the touchpad has been disabled there at all?

What OS is installed?

Update (03/12/2017)

Hi Terry,

Just a thought, see if the following is available

Go to Mice and Other Pointing Devices in Device Manager and see if there is a listing for a USB Touchpad controller.

Right click on the listing and select Update driver. When you get to browse my computer, you'll have the option to "let me choose" and then you select "usb input device" instead of "touchpad controller."

Also have you checked for 'hidden devices' in Device Manager, (located in the View tab option)?

Was this answer helpful?

Score 4
Add a comment

Add your answer

Terry Eastwood will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 4

All Time: 108