1.4GHz or 1.6GHz Processor, 64GB or 128GB SSD.

144 Questions View all

Trackpad clicking but not moving

Hi all,

I have a late-2010 Macbook Air that suffered liquid spill a while back. I have replaced the logic board and it brought it back to life, to one exception: the trackpad is only partially working. The click functions normally, but I can't get the trackpad to actually move the cursor, although I am able to do it with a mouse.

I tried replacing the trackpad, but I accidentally got a 2011 trackpad, however, the problem is exactly the same as with the original trackpad: clicking but not moving. I also tried replacing the ribbon cable (making sure I got the 2010 model this time), but it still is doing the same thing (whether I use the old or new trackpad).

At this point I don't know what could be causing the issue. Does anyone have any clue?

Thank you!

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Mac RAM Kits
Speed up your Mac. Max out its memory.
Mac RAM Kits
Get more memory out of your Mac.

1 Answer

Chosen Solution

Try a 2010 trackpad. Air trackpads are slightly different between years, and usually the click will work but it will not move, if you try the wrong year.

Try this first with the working cable.

Was this answer helpful?

Score 2

Comments:

Thanks Reece.

I got a new replacement for the trackpad (2010, should be the right match) and installed it, but somehow it's not making any difference. Still clicking but not moving.

I tried new cable and new trackpad... what else could it be?

by

The components definitely have the same writing and positioning as the original 2010 trackpad?

The only other thing it could be is the logic board, or an issue with the OS. Hold alt on boot and see if the mouse is moving.

by

Yes the components are exactly the same. I doubt that it has anything to do with the OS, because I recently did a clean install of the Mavericks, and it hasn't changed the problem. Also I had briefly installed Sierra and the problem was the same. Went back to Mavericks since then. Nothing different if I hold Alt on boot.

So it sounds like it can only be the logic board? That's a bummer, since this is already a replacement, that was supposed to be tested and working. Is there a way to fix this issue without replacing the whole board?

Thanks!

by

The only way would be by replacing the soldered components causing the issue. I would honestly just send it back to where you got it from, trackpad issues not caused by the cable or trackpad are usually miserable, and most likely related to the CPU.

by

Unfortunately I bought that logic board well over a year ago, too late to return it.

Does that mean that getting yet another logic board is my only alternative?

Is there any way I can test it to localize the problem and be 100% sure?

by

Show 1 more comment

Add a comment

Add your answer

matmat will be eternally grateful.
View Statistics:

Past 24 Hours: 3

Past 7 Days: 16

Past 30 Days: 69

All Time: 540