Tv powers off shortly after turning on

Hi there, not sure if you could help me with my TV but I have a Vizio 55", model number M500SV. The TV will turn on displays the Vizio logo then does a quick flicker and then displays for me to set up my TV signal, when I go through the options to choose signal I select cable then cable device, then once I begin scan the TV powers off by itself. And before I restored the TV's defaults whenever I opened the menu it loaded extremely slow, and using the directional arrows either way there is a long delay so any information you have would be much appreciated, thank you.

Block Image

Block Image

Block Image

Answer this question I have this problem too

Is this a good question?

Score 1
Add a comment

2 Answers

Most Helpful Answer

@mf81camaro sounds like a power board issue. Check the caps on it as well as the MOSFETS. Post some images of your boards so we can see what you see. Use this guide for that. you also want to double check your TV's make and model number. I do not have any information on a M500SV by Vizio which is unusual

Was this answer helpful?

Score 2

Comments:

Okay so your power board is a Vizio 0500-061200140 and you can measure the outputs of the board on the connectors. IF you want to replace it is not available at Walmart but at places like this http://www.ccfloffer.com/ViewDetails.asp... and others.

by

Add a comment

Well mother board probably needs replacing

Was this answer helpful?

Score 0

Comments:

Where's a good place to purchase one, and do you know how much?

by

Walmart $40 and i have one for you

by

Where can I purchase one from you?

by

Where do you live i live in Kansas in hays ks

by

I will mail it to you

by

Show 2 more comments

Add a comment

Add your answer

Shaun Allen will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 63