Skip to main content

The Lava Iris X8 is powered by 1.4GHz oct-core MediaTek MT6592 processor and it comes with 2GB of RAM. It runs Android 4.4 and is powered by a 2500mAh non removable battery.

9 Questions View all

phone is not opening

i root my device but is work fine , the i just apply custom rom for music player then my mobile is stcuk on lava after gone to recover mod i just power off , now it not showing any thing just blank

Answer this question I have this problem too

Is this a good question?

Score 0

Comments:

Have you tried reflashing it with stock? Sounds bricked to me but please attach it to your computer and see what you can do

by

yes, i have tried still not opening

by

Add a comment

1 Answer

My phone is stuck when turn on the device. Before I tried to root the device . I connected to the pc . It does not show as a phone it shows like printer as like that. It does not show the model name ,no or

Was this answer helpful?

Score 0
Add a comment

Add your answer

hemant2307sb will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 1

Past 30 Days: 5

All Time: 196