Phone refuses to connect to internet and refuses to read sim card?

After attempting to update my BLU LIFE (which didn't work. It came across an error, with the little android's stomach flipped open, though it didn't what, the only thing I could do was pull my battery out after trying to exit the terminal-looking area.), the wireless update went down.

Soon after, some apps would refuse to move to my SD card, and sometimes the SD card won't even read. Now, when I turn the phone on, a black screen with a white square pops up, stating it's optimizing and starting all of my apps.

Just today, it stopped reading my sim card (said there wan't one inserted), and though I'm connected to internet, it says I'm not. I just tried turning my phone off then on multiple times, I switched the sim card into the second slot, and back and forth a few times, and nothing changed. I'm not sure what I should do? ||the internet took almost half an hour to work||

Also, my phone is a custom build, if that may have anything to do with it? Build Version: BLU_L050U_V13_GENERIC 21-06-16 14:46

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Hi,

Have you tried a factory restore at all?

Back up the phone first so that you keep all your data and downloaded apps, as the restore (or hard reset) will erase everything as the phone will be reset to its' factory default condition. (i.e it will revert to either the original installed version of the OS if no successful updates/upgrades have been done since new or the last successfully updated/upgraded version of the OS)

Make sure that the battery is fully charged before you do this. Also remove any external SD card that is installed.

Test if it works OK after the reset.

If it does then try restoring the phone with the backup you made earlier and see if it still works OK.

If it does then the reset has resolved the issue.

If it fails again, a downloaded app may be the cause of the problem. The trick is to find out which one.

Was this answer helpful?

Score 2
Add a comment

Add your answer

A Phone User will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 2

All Time: 48