Released on September 19, 2014, this 4.7" screen iPhone is the smaller version of the iPhone 6 Plus.

3267 Questions View all

Constantly searching and no signal

Hello

I have an iPhone 6 which got kicked by a horse- literally- and came in with a broken screen. It had a bashed/dented frame corner I had to sort of correct as you can see on the attached image. After screen replacement I noticed the system constantly shows Searching..., but it never gets signal. I then decided to place the logic board in another full body assembled phone and voi-la: the signal is there!

I could not find any damaged components, so I wonder whether anyone would have a suggestion as in what to look for.

Many thanks.

Block Image

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Typically if the housing is original, then the first suspect that must be ruled out if your iPhone is stuck on "searching" is that the time/clock is correct. Then rule out the lightning dock which comprises the antenna. And to a lesser extent the upper antennas. Finally board itself can be bad, due to cracks under some cellular-related chips or because the phone is not keeping the time (you can notice the latter: time would always be incorrect).

So:

Either the new housing has a good lightning dock, and the old one is bad. You fixed it this way.

Or the antenna got loose during the incident and when replacing the housing, you plugged it in correctly.

Or the clock was not set and you did not notice it. Restarting the phone in a new housing fixed it.

Or the board is now damaged from the hard drop, and soon this searching issue will become more frequently recurrent. Hope it's not that one.

Was this answer helpful?

Score 2

Comments:

Thank you Rany. I think you have nailed it.

I appears to be the lightning dock, as moving the board across housings I get signal on a random housing(assembled with its own components), but not on its original housing, so I tried powering on the phone with the board installed in the working housing, leaving the lightning dock disconnected and the issue(searching/no signal) reoccurs.

I will try changing the lightning dock and see what happens.

P.s. The clock was correct

Thank you.

by

Sorry for not getting back with an outcome before:

In the end, after a lot of testing, swapping the board and componentes around I discovered it was a problem in the board itself, which must have been damaged with the impact of the horse's kick. There was a dent-like mark on the back of the chassis, so observing that I have put a wedge under the board, between the board and the chassis right along with that dent-like mark- instead of re-flowing anything- and it worked.

by

This will unfortunately not last. The pads will become more and more oxidized, and some time in the future they will stop letting electric signal through.

by

Add a comment

Add your answer

Paragon will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 70