Subwoofer will not power on

This is an amp for a B&W ASW608 Subwoffer.

The unit will not power on. I checked the fuse, cord, and visually inspected the 2 boards. There is not sign of blown caps, or board discoloration. The traces and overall appearance is pristine. I don't have the ability to test further.

Any guess as to what it maybe? Someone said the modulator could be the issue? I'm good at soldering if I knew how to proceed. B&W wants more than it is worth to repair it.

Thanks

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Hi,

Found this in a link which may be of interest to you.

It is from the 3rd post down the page

By internal fuse do you mean the one on the back panel accessible externally or did you disassemble the subwoofer? There's another internal hidden fuse which, according to the destruction manual, should only be replaced by an authorized 'operative'

Here is a link to the page it was from. Be sure to read it through as there is more regarding the location, type of fuse and the possible reason for it being blown.

http://forums.thinkbroadband.com/audio/4...

Hopefully this is of some help.

Was this answer helpful?

Score 2

Comments:

Hi

That is very interesting and will check it out tonight.

Thanks so much for your helpful reply!

by

I checked the internal fuse and it had continuity. Not

by

Hi @joe_c57 ,

Here is a link to the service manual for your sub woofer. Unfortunately you'll have to sign up to a "free" account before you can download it.

Hopefully it will be like most good service manuals and have the circuit schematics. Even better if it has troubleshooting flow charts as well.

http://www.hifi-manuals.com/Bowers-and-W...

by

Add a comment

Add your answer

Joe C will be eternally grateful.
View Statistics:

Past 24 Hours: 3

Past 7 Days: 23

Past 30 Days: 58

All Time: 232