Touchpad stopped working with no reason

I have 1 month old Asus zenbook flip, perfect laptop for me. But today, while I was watching film, touchpad stopped working. Never dropped, flooded or damaged in any way. I've tried Fn+F9 key combo, tried reinstalling driver for touchpad (this message pop up: http://ivanrf.com/wp-content/uploads/201... ) and ATK package, I even can't find the device in device management, on mouse and pointing devices I only can see the external mouse.... Tried clean windows install with ssd format, nothing changed....

Should I bring it in the store, it's still under warranty or you think the problem is software ?

It's like there is no touchpad at all :/

Answered! View the answer I have this problem too

Is this a good question?

Score 1

Comments:

I am having the exact same issue you are, as of today. I was wondering if you ever found a fix? I have tried reinstalling drivers and the ATK package but I get the same errors you got.

by

Same issue with touchpad and touchscreen on Asus Zenbook UX360C and Windows 10 release 1709, I2C HID drivers on error (code 10).

Tried to reinstall the driver from Internet with no effect. Drivers on Asus site don't execute with error "there is a problem with this windows installer package"

I called ASUS support, their reply : "Your computer is not compatible with this release of Windows 10. Either rollback to a previous release of Windows or wait for the next one". Amazing !

by

Add a comment
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12

1 Answer

Chosen Solution

Hi,

Just confirming that you tried installing the latest version ATK package and Smart Gesture drivers.

Here is a link. Install the ATK package first then the Smart Gesture drivers.

http://ivanrf.com/en/latest-asus-drivers...

Be aware of the Notes: near the top of the page which says how to install the drivers.

If this fails to restore the trackpad:

1. check in Device Manager if there is a listing for "Other Devices" at all and see if it is the Touchpad.

2. check in Control Panel > Mouse and see if there is a Trackpad tab option and see if it is disabled there.

Having tried all the above and it is still not working as you have said it is still under warranty , then yes get it repaired under warranty. That's what the warranty is for.

Was this answer helpful?

Score 2

Comments:

Thanks for the reply.

I've tried this too, nothing happened...

I will go to the store after my exams

by

Did you ever get this to work Ivaylo? I am having a similar issue

by

I have the same problem, tried the solutions suggested by Jayeff, and... nothing. I have looked at several tutorials on Youtube, about that kind of problem with laptops from other brands, and it seems that there is always an easy solution. With the Asus laptop, the biggest problem is that THE EXISTENCE OF THE TOUCHPAD IS SIMPLY NOT ACKNOWLEDGED in the settings!!! You will find stuff about a mouse, but nothing specific about a touchpad!!! It kinda feels like the twilight zone. Same thing with the f keys on top of the keyboard, none of them features a touchpad icon... It's just insane...

by

Add a comment

Add your answer

Ivaylo Markovski will be eternally grateful.
View Statistics:

Past 24 Hours: 20

Past 7 Days: 132

Past 30 Days: 655

All Time: 9,202