Released on September 19, 2014, this 4.7" screen iPhone is the smaller version of the iPhone 6 Plus.

3267 Questions View all

Completely Dead iPhone 6 repair tried lots and no joy

Hi, I do small repairs on small devices but this is for MY IPHONE, embarrassing as I can't fix it to date. It just died one day..... and I mean its DEAD,

No response at all and the USB meter shows no current draw whatsoever. I know that this is a board level repair as I have placed the board in a working housing and still no difference. i.e. good battery, dock, screen etc. everything but the board!

I have checked for shorts on power lines and have not seen any at all. The board also looks good under the scope (nothing physically damaged - why would it it just died!)

Now as I last saw the device working before I plugged it into a car charger (yes a crappy one!) I suspected a TRiSTAR problem. So I replaced this IC and no difference, still DEAD no current draw.

All posts and forums suggest for a completely dead device either a short of U2 Tristar...

I am now thinking of the Power Management and Big Power Management IC's. Has anyone else seen anything like this before and have any recommendations before I try these in desperation?

Any help very much appreciated....

Nathan

Answered! View the answer I have this problem too

Is this a good question?

Score 3
Add a comment

1 Answer

Chosen Solution

As you suspect, this is very likely a U2 problem. Depending on how experienced you are with this kind of repair, it is possible that you either have a defective replacement IC or it was not properly soldered with all pins connecting. If you applied too much heat, you may have shorted some solder balls underneath neighbouring chips or on the other side of the logic board. You may also have blown off some components.

Just ideas to check against...if you are experienced, you probably already verified this stuff, if not, then this is as good a time as any to learn :>).

U2 primarily functions as a communication chip. Tigris is responsible for generating PP_VCC_MAIN from either the battery or Lightning cable. The PMIC generates a multitude of power rails. Ideally, you need to test them all to ascertain full functionality.

Was this answer helpful?

Score 5

Comments:

Thanks for the response Minho.... My skills are not the best on the planet but not the worst either. The U2 chip went back on nicely without too much heat. Looking at the balls I can see they look fine to me. I could try another chip but I'm not convinced it is the problem as its exactly the same fault. There are no blown away components they're all present and correct.... PP5VO_USB is present and correct @ 5.19V with battery disconnected so I can get to TP2501. PP_VCC_MAIN I cannot measure but have checked for shorts and there are none. If I remove the board and connect a good battery would I expect to see VCC_MAIN or do I need more connected? If PP5VO_USB is there and VCC main missing would you suspect TIGRIS? Thanks again.

by

its not unheard of to get a bunk chip too...

Pull the tristar, clean the board, inspect for missing pads and try a new chip.

by

In a nutshell:

*PP5V0_USB gets converted to ~4.25V by the internal Buck converter in Tigris to create PP_VCC_MAIN.

*CHG_ACT_DIO will go low (0V) when it detects something in the charge port.

*VCC_MAIN & BATT_VCC are connected together via Q1403 and battery charging occurs.

*When the battery is fully charged, CHG_ACT_DIO goes high and cuts the connection between PP_VCC_MAIN & PP_BATT_VCC. However, due to the #Body Diode in the FET, BATT_VCC can still supply current to PP_VCC_MAIN and hence the rest of the device.

by

Had the battery replaced due to the battery lasting half a day on standby. After replacement it's the same. Completely drains in 12 hrs in standby. Thinking it maybe the U2 chip. Your thoughts?

by

Add a comment

Add your answer

Nathan will be eternally grateful.
View Statistics:

Past 24 Hours: 5

Past 7 Days: 42

Past 30 Days: 207

All Time: 923