Model A1286. Released February 2011 / 2.0, 2.2, or 2.3 GHz Quad-core Intel Core i7 Processor

375 Questions View all

How can I fix my SSD problem?

I've had my Macbook Pro for the past 4 years and have upgraded the RAM and have swapped out the optical drive a second SSD. The main SSD is a Crucial 512GB and this has the main OS which is Yosemite 10.10.5.

My second SSD was a OCZ Vertex 4 256GB which has worked faultlessly for the last 2 years or so. I only put my photos on this drive from the shoot I'm covering then export the images to an external HD connected to my iMac. The Vertex 4 started playing up and sent it back to Toshiba who sent out a refurbished Vector 256GB drive which has apparently replaced the Vertex 4.

When I installed the SSD and tried to Partition it I got the following error message... Wiping volume data to prevent future accidental probing failed. I have no idea what this means or, what's causing it. I removed the SSD and put it in a USB caddy and tried again. It partitioned fine but when I put it back in the Macbook, again, it wouldn't work.

I got back on to Toshiba (OCZ) and they sent another drive (both from Holland). This second Vector is exactly the same and it's now driving me mad!! I will be contacting OCZ in the morning and demanding a brand new SSD but I don't know if I'll end up with the same issue? I've tried a hybrid HD in the Macbook and it's fine.

Has anyone got any ideas what is causing this error and how I can fix it? I have got a Samsung SSD being sent from a friend on Tuesday and will try that in the next few days.

FYI Apple replaced my Logic board as the graphics card was faulty and replaced under their recall warranty. This was done in between the Vertex 4 being sent back and the first Vector SSD arriving. I think this is just a coincidence and has not effect of the problem?

Thanks for your help in advance.

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Your SSD's Specs:

- Crucial MX100 SSD

- OCZ Vertex 4

by

Add a comment

1 Answer

Chosen Solution

Your system is one of these: MacBook Pro 15" Early 2011 (MacBookPro8,2). Now if we look at the OWC Data Doubler We can see there is a note on compatibility on the MacBookPro8,2 (see the note in Red).

So you have a problem with using either SSD in the optical carrier as both of yours are technically SATA III (6.0 Gb's) drives, while they can sense the slower SATA II (3.0 Gb/s) interface in older systems and adjust to it, your system is not SATA II but in-between SATA II & SATA III on the optical drives SATA port, which is why you can't use your drives. You'll need to find a fixed SATA II drive if you can find one. Just to be clear, it makes no difference who's optical drive carrier you use all of them face the same problem as the issue is within the MacBook Pro's logic board.

I think the better solution here is to just get a larger SSD and swap out your primary drive with it.

Was this answer helpful?

Score 3
Add a comment

Add your answer

jghobley will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 2

Past 30 Days: 2

All Time: 49