Repair and disassembly guides for electronic keyboards.

45 Questions View all

keys not working properly

I have a yamaha piagerro npv60. The B & C keys have problems with it. Here's the scenario: - both keys played together, respond to velocity. If you play fast trills or scale, if u hit one first, the next key, either B or C wont sound. You have to time it properly to work. If you hold down either B or C and then press the other... The latter won't sound. But take note, in combination with other notes all is fine. Same issue for the F and F#. This happens in all the B&C and F&F# on the keyboard. Please help! Thanks in advance!

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

If I may add, when pressed together, they both sound. Only one after or before gives me the problem. I' ll post a video to make it clearer..

by

Add a comment
Deck the Halls
With tools and Fix Kits

2 Answers

Chosen Solution

Hi,

Have you tried to reset the keyboard to its' factory default condition to see if this resolves the problem for you.

Starting with the power off:

While holding the rightmost white key on the keyboard (C7) along with the three rightmost black keys (F#6, G#6, and A#6), turn the power switch on. "Clr" will appear on the display.

NOTE: Do not turn off the power while Clr is showing on the display.

Was this answer helpful?

Score 1

Comments:

Hi,

My only other suggestion is that you purchase the Service manual (as it is not available for free on the internet.) In other Yamaha keyboards I have noticed that for certain key combinations the circuit used is nearly the same except for the last connection e.g. on a psr e403 there are only 12 separate power feeds for all the keys. Certain keys combinations are 'connected together' as far as the 'feed'power is concerned only separated at the decoder stage to individual inputs.

My thinking is that since it is only happening on two key combinations, perhaps they are sharing the same power feed and that there may be a problem with it. By power feed I mean in my example the power feed is +3.3V DC thru a 10K Ohm resistor and then to the keyboard key multiple wiring. It may be that for your particular keys that the voltage is slightly lower for whatever reason so that it does not react properly.

http://faq.yamaha.com/us/en/article/musi...

by

Add a comment

I tried this and reset the factory settings. The problem still persists. Any other fix perhaps? Thanks!

Was this answer helpful?

Score 0
Add a comment

Add your answer

Hosea Kenji Baldeviso will be eternally grateful.
View Statistics:

Past 24 Hours: 5

Past 7 Days: 22

Past 30 Days: 98

All Time: 259