Kenmore Dishwasher will not start - no diagnostic code -Solved

I have a kenmore dishwaher model 66513883k800. Most of the lights light up but it will not start. Reading through other forums, I started replacing pieces. I have replaced the door latch, the fuse and now the entire circuit board and still the same thing. It runs through the diagnostic, fills, drains, with no problem, but will not show me any error codes.

What else could be the problem?

Answered! View the answer I have this problem too

Is this a good question?

Score 1

Comments:

Hi, Some perhaps silly questions. But as it seems to work OK when using the diagnostic program and you have replaced the control board I'm thinking about the control panel. Have you tried different wash cycles to see if it is a control button that is the problem? Have you pressed the time delay button in case the delay time light is not showing but the delay time is activated again due to a faulty button?

by

Well I get the same result with both control boards that I have now. No cycle will start. The lights above the button light up for most. Normal Wash, HE Wash, Pots and Pans, China, but not 1-hour wash. Also, the delay start button that toggles between the 2, 4, and 6 hour starts does not light up. I can run the diagnostic and all lights come on before it runs the diagnostic test.

When running the test, it goes through all of the cycles, water is coming in, it is draining, the heating element get's hot. but I still get no code after it runs. I had the bottom off and everything under the dishwasher looks like it is running.

One other thing to note - is there any high temperature setting that could be having an issue. We did have an issue with our hot water heater and the water was getting VERY hot. Not sure if that could have caused any other issue that the diagnostic test isn't registering.

by

It will be hard to prove the problem but if you remove the panel from the dishwasher you may be able to access the buttons themselves and with an Ohmmeter prove whether the button contacts (especially the delay time button is OK.Given the panel is connected by a flex cable tothe control board and looking at the part in this link http://www.searspartsdirect.com/part-num... it doesn't seem to have too many wires so it probably has some sort of matrix arrangement (like a keyboard in a PC) to denote which buttons are pressed.

As the new control board didn't fix the problem, find out if you can return it for a refund and get the Control Panel instead if you haven't got the equipment to test it first.

by

Ok - I'll take a look when I get home tonight to see if I can Ohm out the butons that aren't lighting up. Thanks for the idea! Will post tongith or in AM what I find.

Anyone else with other ideas is appreciated!

by

Hi, Forgot to add the buttons may be OK in themselves, it may be a short circuit between two or more connections leading from the buttons to whatever connects to the flex cable. It may even be diode leads that are touching for example.

by

Show 3 more comments

Add a comment

2 Answers

Chosen Solution

Well we can close this one out. I replaced the front panel and everything is working now. So I guess the theory is that if it won't start, with some lights working and some not, and no diagnostic code - then the panel is bad. Regardless, the fuse, control board and door latch are brand new too! Thanks for your help!

Was this answer helpful?

Score 3
Add a comment
Most Helpful Answer

Hi,

You said that you have new control boards. I am thinking that you have a faulty Control Panel. The fact that the delay lights don't come on or move when you press the delay switch, the 1-Hr wash switch doesn't work when you select it when you have either had the new or old "control board" in points to it. There may be a fault in the Control panel which is 'confusing' the control board as to what it has to do so it does nothing. Running the diagnostics may have nothing to do with the control panel except to get into the 'mode'. the control board is pre programmed to perform the functions and as they work there will be no fault code.

2 part answer

Was this answer helpful?

Score 3

Comments:

Hey Jayeff. I took it all apart again and disconnected the control board to inspect the ribbon and the buttons. Since it is glued into the front of the display I couldn't ohm the button itself out. I verified the ribbon was good, made sure all connections were reset and then it worked.

My theory is there was something interrupting the connection from the button and from me taking it apart and playing with the ribbon, holding it upside down, tapping on it, etc - it dislodged whatever was in there.

Thanks for your help and advice. Dishes are washing now!!!

by

Add a comment

Add your answer

Mike Redding will be eternally grateful.
View Statistics:

Past 24 Hours: 2

Past 7 Days: 6

Past 30 Days: 27

All Time: 186