The Apple iPhone 5s was announced on September 10, 2013. Repair of this device is similar to the previous models, and requires screwdrivers and prying tools. Available as GSM or CDMA / 16, 32, or 64 GB / Silver, Gold, and Space Gray.

3535 Questions View all

iPhone 5s stuck in recovery mode : Error 50

Hi. I am from Malaysia

I had error 50 on my iphone 5s two days ago. first i lost my network connection, then when i connected the phone to itunes to update to ios 10 the udate stopped half way and showed error 50. anyone can advise how to repair this problem since there are so many people with the exact problem around the same time. What a coincidence, lol

Answer this question I have this problem too

Is this a good question?

Score 3
Add a comment

7 Answers

Most Helpful Answer

I would first try to force the phone into DFU mode and try again making sure the cable is original, the battery is holding some charge like 25% or more, and iTunes is updated to the last version.

If you have previous liquid damage or other physical damage that affected your board, it may fail all the restore attempts until the damage is fixed - if repairable.

To force the phone into DFU mode: connect it to the computer, with iTunes turned on.

Press & hold Power Button for 2 seconds;

After 2 seconds, keep pressing on the Power Button and simultaneously press & hold the Home Button (for iPhone 7/7+, the Volume Down button);

After 12 seconds, release Power Button, keep pressing Home Button (for iPhone 7/7+, the Volume Down button);

After maximum 15 seconds, release the Home Button (for iPhone 7/7+, the Volume Down button). iTunes on your computer must be by then showing a prompt saying an iPhone/iDevice in recovery mode has been detected. The screen on your iPhone/iDevice must be black with nothing showing on it. Otherwise you are in "Restore Mode" not in DFU mode, and should repeat the steps above.

Once in DFU mode, click on the option "Restore iPhone/iDevice" that you must be seeing as an option in iTunes. Leave it alone until it restarts on its own.

It may take up to a few hours to download the firmware from Apple, if your Internet connection is slow.

Once done, all your data will have been erased.

If you wish to (try and) retain your data, you may try a slightly different approach:

Turn off the iPhone/iDevice. Press & hold the Home Button (for iPhone 7/7+, the Volume Down button) and while holding, connect to your computer using your USB cable. The iPhone/iDevice will restart. Keep holding the button till it has restarted and showing "connect to iTunes" or the USB cable image on your screen. At the same time, iTunes on your computer should be saying that an "iPhone in restore mode has been detected" and you have the option to "Update" or "Restore." Try Update and leave alone till it restarts on its own.

Hope this fixes it.

Was this answer helpful?

Score 3
Add a comment

I hope this article I wrote will help you with the solution.

https://bold.io/how-to-fix-error-50-when...

Was this answer helpful?

Score 1
Add a comment

I too tried the hair dryer, pressing the power/home button while loading up and on its own but none worked. I read that the heat malfunctions something inside so I decided to rub my iPhone 5c with my hands until its hot enough (2 mins) and then stuck it under my hot laptop while it loaded. first time did work but second attempt did and loaded it fine! make sure your phone silent/loud tab is just on loud! good luck

Was this answer helpful?

Score 1
Add a comment

the battery should be 30 percent and make sure the battery firmness connectivity going to logic board should hold firmly with the batt temp. and current sense of the battery terminal .. run a 32bit OS for windows 7..

and other ways...if it change the touch id sensor.. disconnect that wire when detected to the itunes upon processing ..right away...

Was this answer helpful?

Score 0
Add a comment

save the old version of your i tunes.. when you restore old version...it makes a lot of help...

Was this answer helpful?

Score 0
Add a comment

hello

using the hair drier worked for me .

but my baseband seems not working.

after inserting my sim card , it shows research....

however wifi works perfectly.

https://www.youtube.com/watch?v=rmRwWLf5...

Was this answer helpful?

Score 0
Add a comment

Error -50 means sth wrong with your baseband chip, which is a hardware problem. Maybe you can try to heat up your iPhone evenly with a hair dryer. But provided that your iPhone is kept in the restoration mode. Maybe it would do a favor for you. If this doesn't work for you, just as others said, restore your iPhone in DFU mode. However, if both methods are useless for you, one such program is called iOS System Recovery, maybe it can do a favor for you.

Detailed introductions can be found here: How to fix an iPhone stuck in recovery mode.

Was this answer helpful?

Score 0
Add a comment

Add your answer

devienraj will be eternally grateful.
View Statistics:

Past 24 Hours: 12

Past 7 Days: 80

Past 30 Days: 315

All Time: 6,453