Why does my phone keep resetting and not charging at all?

So after RMAing my phone several times I got sent a "brand new" Alcatel One Touch Idol 3 6045Y, which came with 0% battery. I tried charging it with the official charger that came in the box and the Alcatel One Touch logo would show up for a few seconds, then the battery filling up icon would appear for half a second and then it would restart.

It seemed strange to me so I went to the recovery mode and did a full wipe, only to find out it didnt solve anything. Now I have a faulty phone which isn´t even the one I sent, what would you guys do? I cannot charge it because it keeps resetting and using other chargers does nothing. Sadly, the RMA service seem to have absolutely no idea repairing phones, as the last time I sent it they just did NOTHING at all to the phone, which worked but wouldnt charge right after connecting the charger, but randomly

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment