A tablet released in September of 2015 by Amazon featuring a 7 inch multi-touch screen display. Model Number: SV98LN

20 Questions View all

Device will not boot up?

I was attempting to downgrade my kindle fire 5th gen to 5.1.2. It was going all fine, I had gotten it installed and everything, but when I attempted to reboot it it wouldn't turn on. It is now stuck turned off. How do I fix this, or is it a lost cause?

Answer this question I have this problem too

Is this a good question?

Score 1

Comments:

Hi, Try holding down the power button for 40 seconds. If this is still no good, try holding the volume button and the power button together for 30 seconds.

If you have tried either or both options already, apologies.

Last ditch attempt: if nothing works, open your Kindle, disconnect the battery, press and hold the power button for 10 seconds, release the button, reconnect the battery and try to start it.

by

Thank you for the suggestions unfortunately I have tried all of those, none of them worked for me.

by

Add a comment
Black Friday
Broken doesn't stand a chance.

1 Answer

Amzone Fire Tablet 5Th Gen After Downgrade Dead Or Connecting MTK Driver Showing Device

Was this answer helpful?

Score 0
Add a comment

Add your answer

Theifobia will be eternally grateful.
View Statistics:

Past 24 Hours: 3

Past 7 Days: 26

Past 30 Days: 93

All Time: 315